summaryrefslogtreecommitdiff
path: root/dev-python/pytest-datafiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/pytest-datafiles
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/pytest-datafiles')
-rw-r--r--dev-python/pytest-datafiles/Manifest3
-rw-r--r--dev-python/pytest-datafiles/metadata.xml12
-rw-r--r--dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-datafiles/Manifest b/dev-python/pytest-datafiles/Manifest
new file mode 100644
index 000000000000..2918dfda5410
--- /dev/null
+++ b/dev-python/pytest-datafiles/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-datafiles-2.0.tar.gz 66507 BLAKE2B 7cd2721ae2e447798afe54f858d697321a1bf88f3c307df14186bc71b7a60bdc9fcb2e99a858186ad058c4663eae8b121a5ffa3427e2ab4f76f4b471dcc36234 SHA512 05bb93e973cde8b6030ff4d82f295bdb54a8d0bcec87f0347347baed80c26851a4ea6980621f43d73b7fb843740d58b32aca37de9607117b664ede8928aaa5b6
+EBUILD pytest-datafiles-2.0.ebuild 759 BLAKE2B 1649120a82297b624c14f8c8d1cdc7c6b7e2e52338a49ac2a7826e2a342f5320d1e74b9626ea49ec866df96f7c85cacbd41859f09cdbe4ac63c0bafa67d5721e SHA512 aa026180c915b9fad2b6bcbca9de0990ee5bf02fe59c6d2ab5bb7038fa74cdfff66a3009eba77c34d964224da6214a75560eb47b3e5c41d6186b9fda5d1c39d4
+MISC metadata.xml 396 BLAKE2B 21c4b5d6ad84afc68be054bab12d925572a823fc9f01a02c9736d898ac99071fcaa382ec441e69fe6e332ad6e9614fb51225c4c82ef075d9d52f137fbb3dab39 SHA512 765562303886dfb3732e1df66d9873061014228b9c486a6ea87b6b02dfba839cf13887a359780e211683f2b86fb8d10900bc1a87c47128754aae65784d5b18ad
diff --git a/dev-python/pytest-datafiles/metadata.xml b/dev-python/pytest-datafiles/metadata.xml
new file mode 100644
index 000000000000..d72f80cdae98
--- /dev/null
+++ b/dev-python/pytest-datafiles/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-datafiles</remote-id>
+ <remote-id type="github">omarkohl/pytest-datafiles</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild b/dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild
new file mode 100644
index 000000000000..137aabf6e394
--- /dev/null
+++ b/dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to create a tmpdir containing a preconfigured set of files/dirs"
+HOMEPAGE="https://github.com/omarkohl/pytest-datafiles"
+SRC_URI="https://github.com/omarkohl/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6.0[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_test() {
+ distutils_install_for_testing
+ PYTHONPATH="${TEST_DIR}"/lib pytest -v || die "Tests fail with ${EPYTHON}"
+}