summaryrefslogtreecommitdiff
path: root/dev-python/pytest-datadir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
commit713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (patch)
tree9e9281ff07875c667fb3bf223166de68137f4635 /dev-python/pytest-datadir
parent08b4047e14c989cfb931eff95973837f54ccc9e1 (diff)
gentoo auto-resync : 04:10:2023 - 11:51:15
Diffstat (limited to 'dev-python/pytest-datadir')
-rw-r--r--dev-python/pytest-datadir/Manifest2
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/Manifest b/dev-python/pytest-datadir/Manifest
index 7fa9a023977d..52a9490879d7 100644
--- a/dev-python/pytest-datadir/Manifest
+++ b/dev-python/pytest-datadir/Manifest
@@ -1,3 +1,5 @@
DIST pytest-datadir-1.4.1.tar.gz 7862 BLAKE2B 6ecd0ba76706c2fedf5964b3f6476176b2eb858fff9207b6286f6235d13c173f62fd03abeab2f5e5fd31506ee436c731d9786fe7937620bb1de08bb50f7b492d SHA512 e9a301004275235787de11242fe987665e4fcc89ca2d1168b27686f4d1506e506bdd517658edcbf2aca97b28dcb1869653e16412157b8ef313c1d4146f8cf4d8
+DIST pytest-datadir-1.5.0.tar.gz 8821 BLAKE2B 68250c0100492c501b2752930cc6668a50233a7be08eeec56b99993c2bc21a13a2f6e2a2bd066dd52d58d219cd63b22f0a63fe51b7e16f80dd919f835994b5cd SHA512 6a91bbd7d1ac133c08d5aad3d9b7fa55b9c81dfea1ca5c18f8c9a90a60db4a1e5c09584a4ad0d420007162c507b91d6769a692057ef5be8eb44af6cbd5704f0c
EBUILD pytest-datadir-1.4.1.ebuild 672 BLAKE2B 3137844dc739204ea3168c547b5d91182965c9d0e69e5dbc1d9876bce1dee1f3416be391a9e01a0a36b11f5c08182d239ab7e1caf5efff974067751a99f185a2 SHA512 dc3cf1510485335f8e0160bab9721c7d98bd0e94934b7f9edb2415ea0740fa7ffe40f76b18e367f0a724830f5c8dd3c6db4472561a1f27f74ce96ffa0a0973b5
+EBUILD pytest-datadir-1.5.0.ebuild 680 BLAKE2B de3fa7a979f5c2ffaf4f64203402d6580780b9b8bd0a0e74ddd3d8ecbd557fbc0f1705b5f109c8d9fa00cc4bfe4f7e45f64a5dfb6e63ae760e72c2b6d878d16c SHA512 a429b0341e0f3fb51934c1b05b4b8f00f347573ab1c2b43c5c7ff762371bd9831945c9572b25cfcd0116e2e72eae9c843f8c7318f7af599152669c30f56daeb9
MISC metadata.xml 407 BLAKE2B 01e202ee3ec230335863f2229c12436c6ad0265a0cd4137d8ca300ab90bc557e38b43fcc0ec211d64e61f46bf814804210056a4e514f0e32af16ffaacfc78897 SHA512 504a3f83140a3242706eabdf22907ab0be9b0424212dcb1f1192d28d8f92fc81bb39e82f9064375b964278fe836e4020f8d17dee93f11355da874ea43cdaacec
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild
new file mode 100644
index 000000000000..103e6d22cdc1
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="
+ https://github.com/gabrielcnr/pytest-datadir/
+ https://pypi.org/project/pytest-datadir/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest