summaryrefslogtreecommitdiff
path: root/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
commitc70685892bc3f0b09aea1216ff278f6095f21281 (patch)
tree4f39843e13c4d3bfd7d02fcfde9adf66af6063b0 /dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild
parent6e8f2ebdce568f2c6c7870edbb9db5324a0e300f (diff)
gentoo auto-resync : 27:10:2022 - 09:57:18
Diffstat (limited to 'dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild')
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild
new file mode 100644
index 000000000000..ddd6c606dc8b
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="
+ https://github.com/gabrielcnr/pytest-datadir/
+ https://pypi.org/project/pytest-datadir/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest