summaryrefslogtreecommitdiff
path: root/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild')
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
new file mode 100644
index 000000000000..4410dfb88542
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="https://github.com/gabrielcnr/pytest-datadir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install
+
+ # Do not install license to /usr
+ rm "${D}/usr/LICENSE" || die
+}