summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-cython/pytest-cython-0.1.0.ebuild')
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
new file mode 100644
index 000000000000..60ca2ab4411f
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"