summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/pytest-cov
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/pytest-cov-3.0.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index b338209deecc..752c693323c0 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1,5 @@
DIST pytest-cov-2.12.1.tar.gz 60395 BLAKE2B 42e817c63c9d787de9bfaf804217a1e020d5a38e564df0ce2d43d6b4f0631aee43ccae329f44c6d7ac9a5662776463456d72138fd20c65cf8d0accfe118e1e2b SHA512 4c234178febeba1ce93ec0804c3efe181d5d88db9ac02effe14e62eb3b0f7ca1f8757fb4f360551e0d3e35a3b6207892afea85611a49db6c71a2dbaacabc5375
+DIST pytest-cov-3.0.0.tar.gz 61440 BLAKE2B 85f0b079c4c373191553271e34e78af68ac69ea53e3721aa0d43eb9dd55be935570eb15c0f8b954e4c0de6201c004ddef435ea70b03cfda893ecdcc230c283e7 SHA512 289d1b1e29dcc3461276de4c1bbd3884e4ec957efb7dd4c330bc3f25f1b978cbee64c0e2882b419eee5f9ccf44c9d1a23ce47a1b7cc7e436b9ebe894e4c11ae8
EBUILD pytest-cov-2.12.1.ebuild 1291 BLAKE2B a52a9688ae13e66a349fa326ef3fc90a3560571b454e0a03764224bb9aefb4808c17795ef193eda1f54a7bc931a23099e026ddaa0dee8efd533f8ba499b231bd SHA512 57fa47eaa32e2aa96d78f3968f32775f5009910d2dc97e95f321de0e1553d94970e306b89ac440865041861b6501c8df9bcb7d7fe13a282b0b539e440c2c1cbb
+EBUILD pytest-cov-3.0.0.ebuild 1216 BLAKE2B 46cfb251f8c7bc9ad0b4343c1a204d2585fc353f28b2ee50abdfe629d30e2d14eb591fb7160af264c24b48cf36b7e7116a51b403c0352aeafe23e8f4e23ca302 SHA512 af176d2a371098a0ed1f7a52030aa382563f653efa32e447c5dcf74f3cec229e4e73e7712fd40afaf8aa02b192f258368fdd3ee34f0dd79dc08e594f2554dfdc
MISC metadata.xml 412 BLAKE2B 0d79131c6fd8adf72493a7c333959e065cf4f2231f6c770800b6d05ff9afcc246cd202406bea6e28f6b0fd23ee6197aa8dac2dd59d0a89d9b07741f57e8fa5e8 SHA512 d1aab9ea8042bf810398a4195fd3595a8abbeb060ab38fd7b7e40085c8d5f22ecb78bab02e2331d4588199d88e0d3848413d75a18fe4373ecd9940a3c990c604
diff --git a/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
new file mode 100644
index 000000000000..e8c8e479010f
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+# TODO: figure out how to make tests work without pytest-cov installed
+# first
+BDEPEND="
+ test? (
+ ~dev-python/pytest-cov-${PV}[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+)