summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/pytest-cov
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.12.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 96ae5e5d7cef..3aaf6b741dcf 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1,5 @@
DIST pytest-cov-2.11.1.tar.gz 59143 BLAKE2B 21aeffbc9ccbe6a7c69a08fe3f0013204eb039c6dc9ddbb364a74ad10764e16ce7be0154e27beaab2c8f9b2a972131c4c2421c4aa4557efc18318556056a421b SHA512 19c465f5972ee0ee3b9a2f1a656fdf5457622cb449f73a6f707d377a617807dadda997a6875f0c081bc4c4f7039559c6e7ce820b818db42dfd053c016e1c3b4e
+DIST pytest-cov-2.12.0.tar.gz 59596 BLAKE2B 6eef2c062b687899009fdf7b4ef8825b3eeabc7be09fac897315cb99acb9176d11bf0d7f3704108caac1bddc32d158b88ddc69a5bd4815c1877cc238684abc3d SHA512 fc94abd8c38ff4015bad4f9f23ee4691f376d436c16f4951021afadfb94dd359a46924d3c7c43dc3193641943f88e0eab04429aa57d26a65bc95622e512639e1
EBUILD pytest-cov-2.11.1.ebuild 1278 BLAKE2B 5caea1f7ad6d68330dc1e76a67337176b6bbc4003672cbcd31382ec5898d5f3c30793d453f97e476abf8db65c64f79689a53595d265451e3de013614280e8d8b SHA512 299fa908ca36189fa1881243c82bbba28b7de4c6146e2bbafb4c334ff4a2953cfb0f5d5a553a648d25bda6df0aaa4b92808b0bca1c60b72145746f6f2522f30f
+EBUILD pytest-cov-2.12.0.ebuild 1291 BLAKE2B d6632d8e15b6c9944238aa661d86cf3c680515ab66a3c6ce4752a192b94164c88e10bc62bf0803a127d1ddd771d80b94939a5a99a604708f391ba6a509be9a2b SHA512 ac77e919daa9d0030853606033da27f42a7fe8aca6f96b87400fb455723ec14a57975386854ec1e70f38b8c6c19032d16e7ef9807ed9a2d3f076e722e6f6221a
MISC metadata.xml 411 BLAKE2B 5ecf37fefd3ba802d31a3f7e10a58fb7391d213164cca73117a5723b174b66e29574ef694960af9346df13667e6c203c309e8372086ddd481eca1eda7f843926 SHA512 ffb291dfaa0724a05a65152d6e1d1fcffed59bf260e07e216fb8e097fef0c3aeec320fd75a7c45ffefdd39c1c0e6a50e196a4cea99654fc3e5d768fd3a81dd99
diff --git a/dev-python/pytest-cov/pytest-cov-2.12.0.ebuild b/dev-python/pytest-cov/pytest-cov-2.12.0.ebuild
new file mode 100644
index 000000000000..8763efa3ffaa
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+# TODO: figure out how to make tests work without pytest-cov installed
+# first
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ ~dev-python/pytest-cov-${PV}[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+
+python_test() {
+ local deselect=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}