summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-cov
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest7
-rw-r--r--dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch16
-rw-r--r--dev-python/pytest-cov/metadata.xml13
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.3.1.ebuild60
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild57
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1.ebuild56
6 files changed, 209 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
new file mode 100644
index 000000000000..409ce92d9ec4
--- /dev/null
+++ b/dev-python/pytest-cov/Manifest
@@ -0,0 +1,7 @@
+AUX fix-for-deprecation-warnings.patch 678 BLAKE2B cbf75e452f1cb5225d23d29c8105fc46c03d66b65ad359e84d63780fdff36342b50a5465c4ebcfe1a94d277301de49e5f4822856411e54d939d85d7043a1f094 SHA512 3f20f6ef0514d676259e6bfd5c10c1877c4237a4a87161352adeda355dac693a6a43b8be3b29848feca433a9ead3e96967d8e255b62e3b60d816127eb17c4cae
+DIST pytest-cov-2.3.1.tar.gz 35378 BLAKE2B 758846db0b06ef9534823d3458ad6211b0cfc14b551a6e1737573a5c1c5bb59c23b26d3448ff8a67d65a4293ce75dd8c79d4916d3d9a7db5021db6b907152230 SHA512 79770beb53fbb43b5d68311c2efd0accbfd890ab6dad299da8c1c0b3d26b54d984807313b1507900cda7004bfb50fedc0bd4341cfcfce47849a4f24fc8184f11
+DIST pytest-cov-2.5.1.tar.gz 36201 BLAKE2B ba07d751c7635ee01262a6f2eeffb27393d58afadb625b220237ff9d014ecdda0f18c0b5fd7bdec66fa4a948f2bb70a715af6dc76664e9c573ad56520c8dee1e SHA512 868131d6ea6dd28deec6d653dec23ceb7d3adccfa2c6bcc0a3126bbb11e924e71f200676461b2202f274ce6e14d1799feb0917e3081817d9e8583271c18a43de
+EBUILD pytest-cov-2.3.1.ebuild 1540 BLAKE2B 867cd8e71809be5676ccc8e9d5fc700c9a19eeb38827b659d23ffd9b23a9294e926e8a184bbe4649929ac561a8cf6f81582aa17ea2e57e9e57ac17f1e79df2ed SHA512 ab86d0f5bbe3fb3730335c2f45dc2cdc038e134e9ef17e8fc8c6346ed9d1efc3c4e46ce34d6c24c7e825c722a7847f1996ce57eda9b72a7838f9e9462d97a9e6
+EBUILD pytest-cov-2.5.1-r1.ebuild 1524 BLAKE2B 60342c9217325602a3cffb1536c650b761c94985dbdbf53b10e9198ce815499bd17233cf194eb05ad548c9869e3c538494c5e224fa85d8c744b951d981edd247 SHA512 6d4547cf7b2779aa374e072663ef6142c9b1880d761ab617b022228f520bcd2f4c753572e00db61623a1869e563db71c06eb1d73a50f530d3accebee95a33075
+EBUILD pytest-cov-2.5.1.ebuild 1506 BLAKE2B 57ef01d9e0c9012ca9e00918817c5782775cebd54684fdeaca16bca47439dd1c90ae85828f83b6fefe36295d536ffb6118b140e465dfea52cfc9314677486788 SHA512 2b6b0feeff3186a901c44a759731f18c8edb6aa7e202ce7fe68d620b5decdb82722d5df6806bf9f1681226dd18d6ae9c494d600c8fbd3a15042d3a57ef5ba997
+MISC metadata.xml 460 BLAKE2B acedcc7748c95511d1ebe201052b50e43569250e41f8d08d8eceb3f8c8b10924d64e74f6ff6453896f9fceff2a939f42d21d3013b9a486b007bb922dfd285ac9 SHA512 5600a6e66b683a30d6252699a28fecf727bdbbad6ef40cec0fabb89f5afd3a0cf1e2b8e2b80ffa6cc144ac03f5e7066117d72fc968492bd3b1d6c89a8b035228
diff --git a/dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch b/dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch
new file mode 100644
index 000000000000..a555ca53fc91
--- /dev/null
+++ b/dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch
@@ -0,0 +1,16 @@
+diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
+index 6cbf341..614e53c 100644
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -337,7 +337,10 @@ def test_central_nonspecific(testdir):
+ ])
+
+ # multi-module coverage report
+- assert any(line.startswith('TOTAL ') for line in result.stdout.lines[-4:])
++ # Fix test failure due to pytest deprecation warnings being
++ # added to the expected output. Look in entire output lines instead.
++ # assert any(line.startswith('TOTAL ') for line in result.stdout.lines[-4:])
++ assert any(line.startswith('TOTAL ') for line in result.stdout.lines[-10:])
+
+ assert result.ret == 0
+
diff --git a/dev-python/pytest-cov/metadata.xml b/dev-python/pytest-cov/metadata.xml
new file mode 100644
index 000000000000..14ce7f071662
--- /dev/null
+++ b/dev-python/pytest-cov/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-cov</remote-id>
+ <remote-id type="bitbucket">memedough/pytest-cov</remote-id>
+ <remote-id type="github">pytest-dev/pytest-cov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
new file mode 100644
index 000000000000..9aef7a752f58
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
+ =dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/fix-for-deprecation-warnings.patch"
+)
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..a6f5d0112692
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
+ =dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild
new file mode 100644
index 000000000000..d769afe6c08e
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
+ =dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}