summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pytest-cov
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.10.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 5868ddfc668f..b8a8c32faa26 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,6 +1,8 @@
AUX pytest-cov-2.8.1-disable-broken-tests.patch 763 BLAKE2B d36ec8acb8329cff8619f22cf485d2161d3ddda7740eea7f1516b5fee6e70bc597b1ca5ac79514be06eeccbd22a458381282622404152e7a41def6af3c3b15a4 SHA512 fc301e116072b7d77864f51a973b20274034569015c198fa8c05efa09d5863bbe9534d1ee1d2170a41485f914f4006cc6818332df76292aecb7e229cd61c7a63
AUX pytest-cov-2.8.1-latest-setuptools.patch 1247 BLAKE2B 24ac573f41ea6beff690330b26900e99f7454bbc74bb868246055bbd5ed9385f7fff9e72c4222c855dcfcd06e1cab6ac322ec9c085c3b3fdbb12137f8f64455b SHA512 699c4e0e5e3f0b8b145946fa319d19be4ddd42ab7f565af875ca37df0aac222d2b0af50f13ee52f19cf01c9e799a8b7e60ccf114b59530731f820c91311b1b5a
AUX pytest-cov-2.8.1-python38.patch 2522 BLAKE2B c09196ac945cd4b00acd75e45987be12ad1c8c251b679135fce1c2356d58396bc11b986f6d65ba0b946f5008eae70dcf18ceed68ba1ea50cb39bce303e710912 SHA512 3bd1fc80cfc76bdf643ed00bb59ecee1ceaf3c838f851cd65f844a5297ea33ab514ed441a5807ce6424ac461b10b629a8b6885851cb80336c5836c5f72ca6271
+DIST pytest-cov-2.10.1.tar.gz 56822 BLAKE2B 45eba205a2c6687882445d3554cedc04ad556854f5eac8eb0fab7fda84cdf2736b034dfdceb664293d1add153a5271403eb94585a863676ccfef9ab09727d165 SHA512 2dd575141754a417f34b414ba7e07291c273abdc63a6b7dc72d317c6ec10076b83c2ad78eeefdda7cee1fd6f56932d838602da4dd760a1c0d12095be94c22568
DIST pytest-cov-2.8.1.tar.gz 47661 BLAKE2B 590fd50b69d01a71b20982d8cdbed0698ebe24c290d791bb44c96aa1aaaf77cf1f379d565eb775864c6945facf6d271115236cb44b95e4a4c9bb7cc6fd591acf SHA512 769a17c2095dbe990df148a0105c9e3dc88ac2265ac77ac31448dab6abf6d8cc0d54f5c6ff01fd708bd38700bfea93f57d3bb702bd9bb0a708257d094b2376ec
+EBUILD pytest-cov-2.10.1.ebuild 1396 BLAKE2B eb6d91beeebb87a89f7af47630e53b52e663568bc711c6117beddb534d73c65652e6799ccec1de6639de9cb5018d686db5ce105bf4a3c1cd048b356699e3cbae SHA512 26fe1a217e12c41ba5a830338b0a0d525e21767d199d1cf0f60efc8497094a42007aa435e02dffbafd849be2139d70bb31a9fcef0a1f0667394c447718a65702
EBUILD pytest-cov-2.8.1.ebuild 1381 BLAKE2B d94212fb13d2e1ab3f1f79c2a6025d64f6f514ae9bc7703dfb3359b5f47a560bbfcf2821055578a28c16e41db98c05d4ca0b5e9def8eab5a499cd3904d617dbb SHA512 40ea68bfc2c03f70161d08e367abd29a86e173504511d1e53e53d31f5aa4718a59ae32db3d0d5337349bf14bcf3db2f79952f07bd36048394d724fea087763db
MISC metadata.xml 476 BLAKE2B be2e8759e98061a26e63e9431f2d62f5d66dcad8d1e82c88c53bbcf129511a3e443cb0332ee27ad450740b719d164d4feb3f6e176e3541a58cecd34dea96d9a7 SHA512 380f75130a29a9b4408eba5d9dce8e6a2bae7ed25fe337ca1f7ec99e941f06063ea088a71b3c1c5fd3e0b617fec676dc52e4f76b8b270485aef7993969712e3e
diff --git a/dev-python/pytest-cov/pytest-cov-2.10.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.10.1.ebuild
new file mode 100644
index 000000000000..3b5c7c30a5e5
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.10.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+#PATCHES=(
+# # Bug 597708
+# "${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
+# "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
+# # https://github.com/pytest-dev/pytest-cov/issues/365
+# "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
+#)
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+
+python_test() {
+ distutils_install_for_testing
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib:${PYTHONPATH}" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}