summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/pytest-cov
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index f89078511311..06e017b1f47d 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -3,5 +3,6 @@ DIST pytest-cov-2.3.1.tar.gz 35378 BLAKE2B 758846db0b06ef9534823d3458ad6211b0cfc
DIST pytest-cov-2.5.1.tar.gz 36201 BLAKE2B ba07d751c7635ee01262a6f2eeffb27393d58afadb625b220237ff9d014ecdda0f18c0b5fd7bdec66fa4a948f2bb70a715af6dc76664e9c573ad56520c8dee1e SHA512 868131d6ea6dd28deec6d653dec23ceb7d3adccfa2c6bcc0a3126bbb11e924e71f200676461b2202f274ce6e14d1799feb0917e3081817d9e8583271c18a43de
EBUILD pytest-cov-2.3.1.ebuild 1540 BLAKE2B 867cd8e71809be5676ccc8e9d5fc700c9a19eeb38827b659d23ffd9b23a9294e926e8a184bbe4649929ac561a8cf6f81582aa17ea2e57e9e57ac17f1e79df2ed SHA512 ab86d0f5bbe3fb3730335c2f45dc2cdc038e134e9ef17e8fc8c6346ed9d1efc3c4e46ce34d6c24c7e825c722a7847f1996ce57eda9b72a7838f9e9462d97a9e6
EBUILD pytest-cov-2.5.1-r1.ebuild 1531 BLAKE2B ee39c41850bb4770fbd4c9782ccd20de882ccc2613b31b863a2a9f565227d22648f688b5f4d790926ca213a4fab4110f0bf4e463eb1a950819768a1c848af4ea SHA512 b9aaa24c249b712fa80cc34bbb380ef5909189d6a66145b1fd9f0260b5323bfe4487b81e3d23345e748443c91081dd05a3a00a9a77633c08263cc4e811eeaccf
+EBUILD pytest-cov-2.5.1-r2.ebuild 1533 BLAKE2B 7b7ec65ae91e9ee425975deb9cbc9c61dc430a045264d5ade13f89c87b539f773d76d61340786c467fcb6f470a8677af09178dc3d113497449a1f2aeec918ebe SHA512 dece63461328b15a9e18a986053408ee62d14c9ca938a7bf1881c13db3950e12d5a82611b9514dd268a07a5d8b1b20a6d6a696e1c24f6f9081a25af1c7a784c8
EBUILD pytest-cov-2.5.1.ebuild 1506 BLAKE2B 57ef01d9e0c9012ca9e00918817c5782775cebd54684fdeaca16bca47439dd1c90ae85828f83b6fefe36295d536ffb6118b140e465dfea52cfc9314677486788 SHA512 2b6b0feeff3186a901c44a759731f18c8edb6aa7e202ce7fe68d620b5decdb82722d5df6806bf9f1681226dd18d6ae9c494d600c8fbd3a15042d3a57ef5ba997
MISC metadata.xml 460 BLAKE2B acedcc7748c95511d1ebe201052b50e43569250e41f8d08d8eceb3f8c8b10924d64e74f6ff6453896f9fceff2a939f42d21d3013b9a486b007bb922dfd285ac9 SHA512 5600a6e66b683a30d6252699a28fecf727bdbbad6ef40cec0fabb89f5afd3a0cf1e2b8e2b80ffa6cc144ac03f5e7066117d72fc968492bd3b1d6c89a8b035228
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild
new file mode 100644
index 000000000000..98fb738ccee1
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
+ >=dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}