summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-03 02:25:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-03 02:25:09 +0000
commit384d032fe7e048bb10cc9bc9881835c92d7e104c (patch)
tree59b969fdecd674b649820312bfa0b0f6043c25a0 /dev-python/pytest-cov
parent7a13078cb414752df1133d1767cc29260dc60fda (diff)
gentoo auto-resync : 03:01:2023 - 02:25:09
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest3
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch21
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild8
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 420f0bfb9b7b..3077c89d893d 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1,4 @@
+AUX pytest-cov-4.0.0-pytest-xdist-2.5.0.patch 750 BLAKE2B 018b270c47f1c19c19f9d72da935457a6042bcafa580d85f904d082fda9980d9a34579174b7b08551d6cedfbc6a6c7abd7be0216df0e21be64e49efe9d3dd1f5 SHA512 e8826ae013c7fb4cbe57975821faea9a8cfd2573befb4f961560e650cbced56e2dff3e02cde23e29e0bb5d06ce0d5893dc408c9e244ce014a5766c5a565f8efa
DIST pytest-cov-4.0.0.tar.gz 62013 BLAKE2B af8a12955e3f22cd9dc257874f86c04c3c6e29f4af2d2838f37ca196c4955dcf4007c7b404f31c303d0eef6c3735fa1a6268c3bb9f01ed54860750ca2f83b6f5 SHA512 fb993be4d86b29a44e4f2ccd2309d99ab9fe8e6b291abbc2a8a3fc8b36479491165a242a20bfa9886dfd296fcc827da9984b556fdbe9a3ac496ac5b6ba379012
-EBUILD pytest-cov-4.0.0-r1.ebuild 1622 BLAKE2B 4be244b7d41479a37edfbf05714a41b531462bd9517058dff86202b9148085c2f6f3aaae8f7756e927b388e8277151f52348b14bf813411d7bd534a8c4170614 SHA512 4c38a2e1093bd1a4a0088aa07b8a6f7b556fc286795feb5960fe8635957919450016e3ee36d154842f604b6928a2f835cf7c95acc50b35e74f9ce3e526985216
+EBUILD pytest-cov-4.0.0-r1.ebuild 1687 BLAKE2B 60ba31403563de56c214d30b40779c44522532a524b66cf0977f5a997a116b24c7deb7a6b40f8c2f5da55cb81c24498ff9e0168dd9b42b88e5f25a215d882a24 SHA512 b7f91b039f74d5a1db4d17d9e5b4275dd5f19319402e6a9b528515728b2b81e5df44ce36c7d4d0eae94da50827701f51b19b85e0317a1621e6c6bc9d12cd0e45
MISC metadata.xml 412 BLAKE2B 0d79131c6fd8adf72493a7c333959e065cf4f2231f6c770800b6d05ff9afcc246cd202406bea6e28f6b0fd23ee6197aa8dac2dd59d0a89d9b07741f57e8fa5e8 SHA512 d1aab9ea8042bf810398a4195fd3595a8abbeb060ab38fd7b7e40085c8d5f22ecb78bab02e2331d4588199d88e0d3848413d75a18fe4373ecd9940a3c990c604
diff --git a/dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch b/dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch
new file mode 100644
index 000000000000..6ed3456597cf
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch
@@ -0,0 +1,21 @@
+https://github.com/pytest-dev/pytest-cov/issues/566
+https://github.com/pytest-dev/pytest-cov/pull/565
+
+From 97483386bde4febe7ff48726f887cc6423d308b9 Mon Sep 17 00:00:00 2001
+From: Chedi <chedi.toueiti@gmail.com>
+Date: Tue, 15 Nov 2022 11:18:31 +0100
+Subject: [PATCH] disabling boxed test if version xdist newer than 2.5.0
+
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -1555,7 +1555,8 @@ def test_foo():
+
+ SCRIPT_SIMPLE_RESULT = '4 * 100%'
+
+-
++@pytest.mark.skipif('tuple(map(int, xdist.__version__.split("."))) >= (2, 5, 0)',
++ reason="--boxed option was removed in version 2.5.0")
+ @pytest.mark.skipif('sys.platform == "win32"')
+ def test_dist_boxed(testdir):
+ script = testdir.makepyfile(SCRIPT_SIMPLE)
+
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
index 61bbc23db863..50a1d98287f1 100644
--- a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -33,6 +33,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
+)
+
distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme
distutils_enable_tests pytest