summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-12 19:40:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-12 19:40:50 +0100
commit7e662ec84fc13cef513542e4030f47017d030187 (patch)
tree64f1b39bb0a27aa67a40fa470432a93698cd7d75 /dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
parentb4ef58ede68341d0e00d761505857e965e2b4231 (diff)
gentoo auto-resync : 12:10:2022 - 19:40:50
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-4.0.0.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
deleted file mode 100644
index 00e9dce47cda..000000000000
--- a/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin for coverage reporting"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-cov/
- https://pypi.org/project/pytest-cov/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-distutils_enable_tests pytest
-
-python_test() {
- # NB: disabling all plugins speeds tests up a lot
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
-
- local EPYTEST_DESELECT=(
- # attempts to install packages via pip (network)
- tests/test_pytest_cov.py::test_dist_missing_data
- # TODO
- tests/test_pytest_cov.py::test_contexts
- )
-
- # TODO: why do we need to do that?!
- # https://github.com/pytest-dev/pytest-cov/issues/517
- ln -s "${BROOT}$(python_get_sitedir)/coverage" \
- "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
-
- epytest
-
- rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
-}