summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-2.3.1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.3.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
deleted file mode 100644
index 9aef7a752f58..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- =dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
- dev-python/pytest-capturelog[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/fix-for-deprecation-warnings.patch"
-)
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}