summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pytest-cov/files
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pytest-cov/files')
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch20
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch40
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch52
3 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
new file mode 100644
index 000000000000..660db5e59431
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
+index e79e9aa..e5ef2c1 100644
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -820,6 +820,7 @@ parallel = true
+ assert result.ret == 0
+
+
++@pytest.mark.skip(reason="test is broken")
+ def test_central_subprocess_change_cwd_with_pythonpath(testdir, monkeypatch):
+ stuff = testdir.mkdir('stuff')
+ parent_script = stuff.join('parent_script.py')
+@@ -951,6 +952,7 @@ def test_invalid_coverage_source(testdir):
+ assert not matching_lines
+
+
++@pytest.mark.skip(reason="test is broken")
+ @pytest.mark.skipif("'dev' in pytest.__version__")
+ @pytest.mark.skipif('sys.platform == "win32" and platform.python_implementation() == "PyPy"')
+ def test_dist_missing_data(testdir):
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
new file mode 100644
index 000000000000..8a9618c3fd98
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
@@ -0,0 +1,40 @@
+diff --git a/setup.py b/setup.py
+index 1305b23..3a5803e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -29,7 +29,7 @@ def read(*names, **kwargs):
+
+
+ class BuildWithPTH(build):
+- def run(self):
++ def run(self, **kwargs):
+ build.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.build_lib, basename(path))
+@@ -37,7 +37,7 @@ class BuildWithPTH(build):
+
+
+ class EasyInstallWithPTH(easy_install):
+- def run(self):
++ def run(self, **kwargs):
+ easy_install.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.install_dir, basename(path))
+@@ -45,7 +45,7 @@ class EasyInstallWithPTH(easy_install):
+
+
+ class InstallLibWithPTH(install_lib):
+- def run(self):
++ def run(self, **kwargs):
+ install_lib.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.install_dir, basename(path))
+@@ -57,7 +57,7 @@ class InstallLibWithPTH(install_lib):
+
+
+ class DevelopWithPTH(develop):
+- def run(self):
++ def run(self, **kwargs):
+ develop.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.install_dir, basename(path))
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
new file mode 100644
index 000000000000..6292672b6191
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
@@ -0,0 +1,52 @@
+diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
+index e79e9aa..198478b 100644
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -662,6 +662,7 @@ def test_fail(p):
+ ])
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="Seems buggy on python3.8")
+ @pytest.mark.skipif('sys.platform == "win32" or platform.python_implementation() == "PyPy"')
+ def test_dist_combine_racecondition(testdir):
+ script = testdir.makepyfile("""
+@@ -1018,6 +1019,7 @@ def test_funcarg_not_active(testdir):
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif("sys.version_info[0] < 3", reason="no context manager api on Python 2")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
+@@ -1059,6 +1061,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
+ def test_multiprocessing_pool_terminate(testdir):
+@@ -1141,6 +1144,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ def test_multiprocessing_process(testdir):
+ pytest.importorskip('multiprocessing.util')
+@@ -1171,6 +1175,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ def test_multiprocessing_process_no_source(testdir):
+ pytest.importorskip('multiprocessing.util')
+@@ -1201,6 +1206,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ def test_multiprocessing_process_with_terminate(testdir):
+ pytest.importorskip('multiprocessing.util')