summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-2.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
commit8bcae5a5a332db9dc28c20b7a5f28337d8335254 (patch)
treef5e955d5d9283743bda70a7d99a915db594b8a50 /dev-python/pytest-check/pytest-check-2.5.3.ebuild
parent74dcbf5a63cafe2678e2a397e1002dd691425200 (diff)
gentoo auto-resync : 05:04:2025 - 01:34:33HEADmaster
Diffstat (limited to 'dev-python/pytest-check/pytest-check-2.5.3.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-2.5.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-2.5.3.ebuild b/dev-python/pytest-check/pytest-check-2.5.3.ebuild
new file mode 100644
index 000000000000..c0c5c022b5c4
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.5.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.12.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest