summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 17:17:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 17:17:39 +0100
commitf66a06e8f9736ea679bc3e95d8c8e90ff7c3f466 (patch)
tree6e12e70b54f33f9219df2139130612649af4161d /dev-python/pytest-check/pytest-check-2.2.2.ebuild
parent92a9a3adda432ad2b7af58e08f5493ed6dc81196 (diff)
gentoo auto-resync : 22:09:2023 - 17:17:39
Diffstat (limited to 'dev-python/pytest-check/pytest-check-2.2.2.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-2.2.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-2.2.2.ebuild b/dev-python/pytest-check/pytest-check-2.2.2.ebuild
new file mode 100644
index 000000000000..2b390b088d17
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest