summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-2.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
commit2e4747a36a51fd58c21f3f00db959709e83fe08b (patch)
tree55b3fa7393c53b4b2fa2bb96fdae27d9d4444a97 /dev-python/pytest-check/pytest-check-2.1.4.ebuild
parent5c1e419582680cfb61e0ae777c693704f3a731e1 (diff)
gentoo auto-resync : 14:02:2023 - 07:56:50
Diffstat (limited to 'dev-python/pytest-check/pytest-check-2.1.4.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-2.1.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-2.1.4.ebuild b/dev-python/pytest-check/pytest-check-2.1.4.ebuild
new file mode 100644
index 000000000000..c6cff2ff6c09
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest