summaryrefslogtreecommitdiff
path: root/dev-python/pytest-catchlog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-catchlog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-catchlog')
-rw-r--r--dev-python/pytest-catchlog/Manifest3
-rw-r--r--dev-python/pytest-catchlog/metadata.xml12
-rw-r--r--dev-python/pytest-catchlog/pytest-catchlog-1.2.2.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-catchlog/Manifest b/dev-python/pytest-catchlog/Manifest
new file mode 100644
index 000000000000..92e6f2cab52c
--- /dev/null
+++ b/dev-python/pytest-catchlog/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-catchlog-1.2.2.zip 18028 BLAKE2B aecc020f34010f20ada7a65b069b5f6de79de301dffd765a0f395127582a90e7913057332a760de38e20f273f0b1ff6dd5afb39f5b3ee1d1e2f2f1e4187eb252 SHA512 bbeeb7213898844a7956712992ddaca1e28c52fc5712339b9730f181a124af5ec90b5460981066638658246da4321840a7583ee14eec7c0482e069e2a824d031
+EBUILD pytest-catchlog-1.2.2.ebuild 793 BLAKE2B cc94ce4c0d36ae83e2bc15e12c4c43a99fae98766f0e4c65e28385a631a9e58a832dd9ee28cb10bbf1b4405b319c8271754482f020bfda6f01dd3bf81467a5af SHA512 59851bdc9a62d0f187cea1e2db547488d3a606e6a4a891e44908f6e19e6d5747622632410958390b37c9e92e22af6488606486699bf747c4328bab626aeef8b5
+MISC metadata.xml 384 BLAKE2B 0dff6cbe91087adee6e5fba8d8d1e38ad51f94d97808c62d7e68844f5eb9097ce4fa22bd7a2e19456836721880fdf4e54d4abab42fc9c1285d6fdf5bc761a27c SHA512 2a49b6a72107bd42dbb524a060c14a2dafc1172ea5d21427f22589f43f7cf728e0b3d843f59c962bcd8c6a072663ab842606d13827ff9803d1a016da5c09f741
diff --git a/dev-python/pytest-catchlog/metadata.xml b/dev-python/pytest-catchlog/metadata.xml
new file mode 100644
index 000000000000..ebb00878d434
--- /dev/null
+++ b/dev-python/pytest-catchlog/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-catchlog</remote-id>
+ <remote-id type="github">eisensheng/pytest-catchlog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-catchlog/pytest-catchlog-1.2.2.ebuild b/dev-python/pytest-catchlog/pytest-catchlog-1.2.2.ebuild
new file mode 100644
index 000000000000..aeb1aa05c166
--- /dev/null
+++ b/dev-python/pytest-catchlog/pytest-catchlog-1.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to catch log messages, fork of pytest-capturelog"
+HOMEPAGE="https://pypi.org/project/pytest-catchlog/ https://github.com/eisensheng/pytest-catchlog"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+COMMON_DEPEND=">=dev-python/py-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${COMMON_DEPEND}
+ >=dev-python/pytest-2.7.1[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/pytest-capturelog"
+
+python_test() {
+ PYTEST_PLUGINS=${PN/-/_} py.test -v -v test_pytest_catchlog.py || die
+}