summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild')
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
new file mode 100644
index 000000000000..ecb5f90c44be
--- /dev/null
+++ b/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-cache http://bitbucket.org/hpk42/pytest-cache/ http://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+# https://bitbucket.org/hpk42/pytest-cache/issues/12
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
+}