summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pytest-bdd
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest3
-rw-r--r--dev-python/pytest-bdd/metadata.xml13
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
new file mode 100644
index 000000000000..8b9e387c8ca3
--- /dev/null
+++ b/dev-python/pytest-bdd/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-bdd-4.1.0.tar.gz 61079 BLAKE2B 3bf7863b7244e0fa02de48f3c8d113427c9a9d546d1a5d95dbc025bcdf0bd60931fac55d7328c96a3b29b8b15da833c85c089cee19ee4f8a2bc639dd1b3c4e59 SHA512 54ce5ae2f7b3deff7d436d42f80fc47892707eb1e6e76469dda9753ff0b2d727bb47b5be300eadccadd87838aee43130fec5dff6441353eb07c0787c84d55afa
+EBUILD pytest-bdd-4.1.0.ebuild 939 BLAKE2B f67df4703d0c974a691cf40b227022bcad97f011632c9fc47f8d2248c4780d09632779475cc6b965db403a4f7bb2ea38d7ea08c3fea348345b38e3e129b5d31b SHA512 e8192818e056a3e7f3d38780549ad62c6a68bddf349421b36f5be726f890b5397c81e869034bac6a61e1212951cbc5d6dac9b33f359149900416e98477938bd0
+MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/metadata.xml b/dev-python/pytest-bdd/metadata.xml
new file mode 100644
index 000000000000..e5bcfe846403
--- /dev/null
+++ b/dev-python/pytest-bdd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-bdd</remote-id>
+ <remote-id type="pypi">pytest-bdd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
new file mode 100644
index 000000000000..dd0a77e782fc
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/glob2[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+EPYTEST_DESELECT=(
+ # result varies depending on current output terminal width
+ tests/feature/test_gherkin_terminal_reporter.py::test_verbose_mode_should_preserve_displaying_regular_tests_as_usual
+)