summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 16:32:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 16:32:24 +0000
commit3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (patch)
tree3d2de0ea329bfae5fb1acd465386966d5ee95422 /dev-python/pytest-bdd
parent91b873ea3e20149dbb554dc214611efa4627962a (diff)
gentoo auto-resync : 09:11:2023 - 16:32:23
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild43
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index f439b48c3c93..f892a65661ac 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-bdd-6.1.1.gh.tar.gz 79549 BLAKE2B 0de77a2a46c852dcd7b344b385deea6473ec32dfec2eec610ae04d9d192d42eaf7aa3b1455549dc602e46c24edf078c558f2564aa9dd7f42a2beea36458438ea SHA512 69cd345d4a819a84a811ca2a5825f87a46fa4d063b9a852308d36e4f15058a27c45b170dadf684e68322d3380654f985b8ef153e34ad42ef33e0b595f8dc9d96
DIST pytest-bdd-7.0.0.gh.tar.gz 80196 BLAKE2B cb34f5439959e93ccb68c566e284d1789a183dd85c1c3088d0c929373e88bd994de2ac159ea942119183976e64903cf7ca8f2b2137aad749f8b67728c541ee89 SHA512 0f95334a56ff7ccc774e5b94b91d232b829fb308a21ce975c88720493abbefa9e76fcd35cc2ca9bbbf0fd2e38b6f20f5be6cf59368aab4cf70abdaf24c7fd5ed
-EBUILD pytest-bdd-6.1.1.ebuild 1107 BLAKE2B 06ecdb413add11a1173c9c83a711d79d1f3b13109f19db30b7eaae42f68613c76147e52afeef300e3762c3e8148ddf195f5cfdedc4da5a00b628429c19a6aeb3 SHA512 00708a10ab77e3db8a05bb2ba569f7fbfc82264856310839c6c66425156e3a52e99004510916184a26151d605888b7adf4f62bf910ece9be08c9a6b3075f90da
EBUILD pytest-bdd-7.0.0.ebuild 1112 BLAKE2B 34938712d30914672175472ee0473854eeef5130b18f7b1783da716ec67bc58372bff5845a960b4b0330b9075676321053f6e5b8adc9627e395ce9a4fd2e3bef SHA512 8840a217fd671c215228170007e960c108bf5c1eb798bd4f34f8e3cd4842fa905ed93af989d7e3302e9aa8dbbd4001ec92d4681515c8a5623e98289d72b8f1ab
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
deleted file mode 100644
index 314501e8d553..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pypi.org/project/pytest-bdd/"
-SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}