summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
commit34d4f34516ab568ad4ea24fc16ee0ad9ec8ad079 (patch)
tree3339f6fc30715c2fbe1d20281f6ddc53eda3f9b4 /dev-python/pytest-bdd
parent32eff0cac517b699efc32b86520bac482961a57f (diff)
gentoo auto-resync : 11:08:2022 - 14:19:56
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild39
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index da58042bcc58..1dc5c0a88595 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-bdd-5.0.0.gh.tar.gz 61174 BLAKE2B 6dd1d53614226d3515b0f61f71822363b559aa45789bab7f3416c75e603e87a1fe48627f36862f44bfa7ac6ec5023ad8afde6054ec67fc9a2e756be7de729fd1 SHA512 827e57d410b05207b6c646062ddb54b677e22441311820d3bd406df202b6e9344dedf59cd4868e89cfbf8606fe3f15559e4cc3958d100e4fa74f9b864e6faada
DIST pytest-bdd-6.0.1.gh.tar.gz 60932 BLAKE2B 67e0dbc251ce94da40033641f37e6c9ad70ca947f71db1a78907a6890d96d8d3112d57a2a63dda526c8f846010d39a575cb5d93a102f4653705d4229ee14ab07 SHA512 30bc697ae177e3f311af0c781e99bde5b491dfef28109359c0d80f33feb8b0b170ffe15c288fe73a624144a1d1c3223b220d591b4acc30d1ad53600482bef87d
-EBUILD pytest-bdd-5.0.0-r1.ebuild 1037 BLAKE2B fced384bd393f3371d5ba248728f9c5ec7a43b3f746ae9e1b6550c320cb4dfc2427ae725b339ee0a54dc729d800b1b5584eac34ec149bcb5a90837ba64416c9b SHA512 c475eeee113ff2ce20abeef242a80e805dd516a206e5b491299b445cbf169ad8b8fbb5c1cd0e43b8beb899028ed343beee61e1e64a522c2ebaa927a0ae3a822b
EBUILD pytest-bdd-6.0.1.ebuild 1084 BLAKE2B baa7bbb71d57683cb4b03dc4fb15ffb510d214df05fdf714767767a73846b6543188ab4af6b931db3c3362cad3b945e271979837f1168a04dcb32c9acdf06549 SHA512 2df002e33e225db79ddb3f6afc9c70e7d1d6f0ef29aad3c8f44189cb9b86faa430053dcba31c3ddb2ce6f8ba5367873d61688b0cc6ffc3208af49868eb566118
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild b/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild
deleted file mode 100644
index edc44c97450b..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pypi.org/project/pytest-bdd/"
-SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/glob2[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}