summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-22 14:47:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-22 14:47:12 +0100
commit1802160f23e91c618b3c7379fd99127682cfce19 (patch)
tree094c5349b2f0bd88633709f2f1ad322398475815 /dev-python/pytest-bdd
parent439c34b3917f0757b9c83eb64a687cac0d477140 (diff)
gentoo auto-resync : 22:09:2024 - 14:47:12
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 8b9186fbc647..8c5d491162c4 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,3 +1,5 @@
DIST pytest-bdd-7.2.0.gh.tar.gz 81301 BLAKE2B e47ec5873546596e913453f86d7c0654b8212de74b0bfa46022da093fa87191c9303559ec670bd37f94e282973192596c77a1f7293a608ae8dedbd863fc245c2 SHA512 d0991feb446f264f0f114693dccb67682a10a427cb5fda28dccafd67cc37810e00c34e3235bb38d02b7fa1edabf1359c6c119be9cfdce0ccf00235ca3dde337b
+DIST pytest-bdd-7.3.0.gh.tar.gz 81595 BLAKE2B 80c5323ba3c50fae17bb57ec26b968ca7d7b673d2aeb2716dee02e3543916ca8b5752d9af56d3d250f3a4b0a857a3dc760de615f0650eaf379380fb24a5b7c2a SHA512 e7c309552714a77d47e437a825e661dbf201a6945e84f4b611b5c3da3d0b4ceb535bde4809fc9633b82a74e2b52cc69c7e14b27a27032c7e4400727498442e29
EBUILD pytest-bdd-7.2.0.ebuild 1044 BLAKE2B 134bef00e9c40656709015f7e8ca045b1ff0b79be49c21e3924c36985e85ac10c1b282c9fc9ff85d34a47dfd1caf54e937fe728ff87a5d63a77e34566aff0b6d SHA512 2973d27c6499113e3703d57cd00bc571769ab00a72fc75170f97ac06a8e51c1d803341c072bbfde751fdf39c3cdae1f2a927f3cf4cc8d0c280ff1c7941885e0a
+EBUILD pytest-bdd-7.3.0.ebuild 1245 BLAKE2B c05b2b4003809080ef097ade3ff3bee0de9c2d12dce7a77bfdeed4e9da70e8cead2129d45595e3c9e5a9e6e122d418e567c696f2a3e650baa06993c25e4fa224 SHA512 9d384fe0e429c18387f07db2c7d979a4cf61e73a5882684b2093769207598620e8a6593573412d287be72db8bfe5abea383ccc9ec45d7afcf31e9b086d7a2100
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild
new file mode 100644
index 000000000000..d54168cbf160
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: may be able to switch to pypi tarball next bump, also wouldn't hurt
+# to build the formerly forgotten docs if the tarball includes them
+# https://github.com/pytest-dev/pytest-bdd/issues/703
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pytest-bdd.readthedocs.io/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse-type[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}