summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 20:03:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 20:03:12 +0100
commitf6652ef9c05f9bc15eab1ef2f902f66314418caf (patch)
tree5bab1be3699d2091e75e1731bcde8f2976c534f1 /dev-python/pytest-asyncio
parent5560910b8e280aa828f26c34b4e361b44f5227c4 (diff)
gentoo auto-resync : 21:10:2022 - 20:03:11
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.20.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 1ae589088f9d..18dd172972b1 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pytest-asyncio-0.19.0.gh.tar.gz 25754 BLAKE2B ee1e028021d7adaeef77e9dc9c1cc0d1a8fe5ee91777b2774d8f175e7520f7f1ae6d058d758964a052d2fc02d369a9dcb522edf8271b54b9b724555222592e29 SHA512 7be87e6edd28496713ae5cca396fed67d372f2882dd573a8b72a84ebf6d262060cda9372bcde601130c42fc27faf15cf292cd820995ea93a324c209f203e823f
+DIST pytest-asyncio-0.20.1.gh.tar.gz 25425 BLAKE2B 90ab8ebdb854b78b0e910b26ffeab4841f0e6dc122bd8c12fa908a59e125473770bac553a8046be37679222016c204c83d9e01db27f6eca765fb3d9b6461d090 SHA512 994b942bc6452bd3972070d1eee3d88c6680a818ad38d6ed5ffa1faba51473227c838eaf24316c74479e7bb9faaf7fd3cbd1e5a07c2611f0e2eaffe369f75d95
EBUILD pytest-asyncio-0.19.0.ebuild 1224 BLAKE2B 6887fdaa0612498cd6eebabc646a5d15dc4f87956c05a39078a508dab106a334827bbb74fb1481af114da09681c248488f723b78b39fd9f74dfb7d861685495d SHA512 876ada06f6771c44ce14bb5414bf7cf12bcf499ee9366d116a49c0b806b7e20517e9235c496849fc14b154d033ad4be49be45df15c59b572e34fe53a538ac5f9
+EBUILD pytest-asyncio-0.20.1.ebuild 1274 BLAKE2B 8a3f8ca38d8eff67fee2d5bf0cc46d08e16aa96ac505a62a57defffb1c5beffef5174f1aad5f60d52ff36868d1c669d8a71e6793942eede089531cd4d00b3ade SHA512 5eb79e4f095bde563a4dafbc24db127b50c1bef8c036e10fafae9c1176416a26b5dc2d9954e1fb80a267ab71cac28b9bfc614f15fad175425f68a5a7e0b63d43
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.20.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.20.1.ebuild
new file mode 100644
index 000000000000..f52a6a0ee6c5
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.20.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/test_pytest_min_version_warning.py
+ tests/modes/test_legacy_mode.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
+ epytest
+}