summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pytest-asyncio
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 10079236b060..ad6ce74c75ce 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,6 +1,8 @@
AUX pytest-asyncio-0.10.0-py38.patch 7093 BLAKE2B 013901feddc45c5e5e832c5d2e016a1ccc4e8be29414ff350baf87b434fa29a803e030f7d4fe869e1276bce079cc075e0e876e8ff29cb6fa5f3abca5c83e77c6 SHA512 d9c3df879b288821a87a7dc1ca55e86e60007128af7dbdf54c7221b7f0c05b7750f8b1e7389a0956d5188d82f0ef8144678437e1391951fe0cfa63c872286ff0
DIST pytest-asyncio-0.10.0.tar.gz 13968 BLAKE2B 4e63d527b20c767b8f0777ed684a15abe54009be72db8a50ca3b37ef95dceb884168d8081c651e2bbd6d818529d6809bb3498055fedc7f951f5675d58f50e408 SHA512 78160d1918c5d3d2172f74fa07bf4bf6d0bc416666011dd5b83b3a7f385ec30fc65d49c01bba5dd0e16ad9dcd9d72d8ab062526f3268d60cd2e24a35b5a8f883
DIST pytest-asyncio-0.11.0.tar.gz 14070 BLAKE2B a97cc52a013e126c7aa48b21e8fdfb69c589efffefdfe0f1cef09ce98c1dd150f4298bfa9d707dfc264a6d48c71839847f929237204ba2a36e1bb1aae4e95cbe SHA512 db1d6a9c4b3f6f24014eacf3b108d76e5b2d6761d35260f20023638cd898b6f0b499dd475bc07abd58bc73bee2a88b565c3ebcced2460e619a1b375fa6a27a64
+DIST pytest-asyncio-0.12.0.tar.gz 14294 BLAKE2B f62bb025bd3e35b5b4571b232ae2dabe5ef42075fa98f2f5ba28f78f16d81eadeb68b7dcd11a9f8170c1077c331c7abbb0fadc02863458ef03d238b399e6f37d SHA512 2e69bfff3f0b35cc82381b841229749d309967ce1d36972933f5bc6d5dff45934608310ed3fa1805dc38ab41bf913a881493c28d6d0e9be733b624cd2fda97d3
EBUILD pytest-asyncio-0.10.0.ebuild 833 BLAKE2B 7474a3709b045c8ba57623907eeb2fec75edff8f09d27be3ce9957c7dfc31836655ff2020a6c287a877df6705e9c11805bc33a870e8d407e076b3479f7cc6f48 SHA512 0211e34d00b6761465d543920a5341f5043317cc4d86a94401606647013efc3be81ea83e4d75ba9e1ef51f70ce00f26b8a590cc1d7635c4be7f24fd78a3fc3e5
EBUILD pytest-asyncio-0.11.0.ebuild 762 BLAKE2B d55984ddaacc624f1f96457811448e4d3d9af28d8ab9ee5610b0def42beca68b2c6294afec80f55324451a623e3ed40151fac52f662eb35eaccb2bea22358763 SHA512 66f3e6661bf185adae6304480f4f5fec32ea0c8ea75177f8ce9111e00f87e7d8fc4b5bde230e7dfa3fe9899140d1ede0d4a1b42bf35dac5c8b8ba3dd887e8cb1
+EBUILD pytest-asyncio-0.12.0.ebuild 800 BLAKE2B ad4e153acc08d27630afe2a07e72497ce4b22276ab789aaff433d5715f2444edbc8d18b134e8176200bb85833901ffa3f82d3d078c26aac321539457231d55e7 SHA512 a40221a64303cb63302245a140f73de68cf36d80516caacfe7f69d43c80728904519dd9b0c433f89d4ce13908969ff9a2c19c215e0c4cff632da80b9f01377f1
MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild
new file mode 100644
index 000000000000..1f152ee53af3
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0"
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}