summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-03 16:59:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-03 16:59:44 +0000
commitc62565378cd5a3feb54906f6458ca268db51a31a (patch)
tree7be47f380dd4086217e29f905280ab4d1d3bd2bc /dev-python/pytest-asyncio
parent09abaf880cd5b1ca2d0d7c320780f91fb3a0428f (diff)
gentoo auto-resync : 03:12:2023 - 16:59:43
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index ae753822730b..45bfc93dfd32 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,5 +1,7 @@
DIST pytest-asyncio-0.21.1.tar.gz 30492 BLAKE2B 6a17f9ba89b8181b5fb734af6d0c0904a828156e63df910b4fe4adb9b93e240266063dcca8d97c8f9d784c6d5111796949fe32bb2832921919e41398ccffc155 SHA512 3aef14bade1dddab4320450d60c6909a76c7cf334d8225ad155b474b042d1c692edc5b567fb86ecf6b3453746105c3cecce86d2c6ff5cf6652d5147a8532cfd0
DIST pytest-asyncio-0.22.0.tar.gz 37081 BLAKE2B 62941bdf10ee8a5195e900e71c7eba1810edd9721457656fc0b62dca3264f4ce0cba9221f80fd8a5249ee30e662cf068fcc8e491ba6b297e0370fcb04b7fe068 SHA512 7880b03c44997b0cb05b1c9633bf3e94e7eefc0396dc88512baf0e8f700508fa76eb9cbf2ce6d837be9ae0f1efb75343cdc32c7b2983e294ffa30e94893a3a2c
+DIST pytest-asyncio-0.23.0.tar.gz 43658 BLAKE2B 893b446018ce460825555b1f42c36b27a0c2330d08e7588a4f59e8b6390390040b49cee02f27369f3135e95402eab7e3573bbae381e5ce81f23e578b1f21fa9d SHA512 903ec009617385c2e95fcb03e1fe23b5d372f5aaa334c5156b0fe19aab7c3d0272e7e5869a89a6b1c4b3282deba5e37b0832a54518455e48af0ef2a51f4b9ce6
EBUILD pytest-asyncio-0.21.1.ebuild 1544 BLAKE2B 5d26765ec0f856550e5246ab1bad7fab1aac0b90837b9a58f26ca5ebc158a5ecb92c356a4d6c3f262bbdeb768acace9c0e9ad06fb074bc255cee7600ab4fb0f4 SHA512 17162c9aae7aec78bfa371f01dc29b252ba0c96c79dd4dd3958f2a2648606ea07c122257456d2bc3e608c60b2ddc9c00813b1faa13fc12c70fef9c1ad6e8e529
EBUILD pytest-asyncio-0.22.0.ebuild 1422 BLAKE2B bea4fa88e677d12627e6ad0586212774b71162329c46a6e4d7c71bf988a65dbb786154862bdce830e8f634a0864887870a089bfbe758622e3054c339e322ff20 SHA512 294ac7331ad6ff685dab0531560678b159d8e313069f5ae019bc70da44f47a00e7a3bcaff6b2be05712a52888ed6c76c4eb866dde09cdf2ad5ba4c7bcec8661c
+EBUILD pytest-asyncio-0.23.0.ebuild 1510 BLAKE2B 6b5d8de5e8041ecf1924f1b6a3b884bbaeadc483dc08d8790359e281e10f3c13e428faf943397aaf782b2f5307de14cc1756ee5379f276b1ed1c13695711fe5f SHA512 84f1db73fcb9b7400f3fe15f3a0fb176d63c7d3c32b6c63c807f2db88d39bdc8af4e0b6b630a0e2def58c7c313edd70c5a32231a6a55aea19ef2d216b130503f
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.0.ebuild
new file mode 100644
index 000000000000..c35e42670f46
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.23.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/modes/test_legacy_mode.py
+ tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ tests/test_pytest_min_version_warning.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}