summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-01 17:49:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-01 17:49:46 +0000
commitc16ac3f2fa4ccc7440fd13db1e5872a3e319f48c (patch)
tree4a3b9bbf32f7a7f613e6b67f3af294606333846a /dev-python/pytest-asyncio
parent94605f5ed96183fd23685900c001b8cf2047c521 (diff)
gentoo auto-resync : 01:01:2024 - 17:49:46
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index de594a7ad547..b87fa80fe069 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pytest-asyncio-0.23.2.tar.gz 44174 BLAKE2B 36dbd0022416eef05c781b9f74fd143bb52fe0583461ca7e52fd4981d552bbefdddd8e3a3399bc229a8ae68b150e199237ae0ce3a375075ab8f7f507bfa59316 SHA512 aa5b5fe8b633b187303dd2958d2ea01561604044507da107e46115d9bf4c1ac3c78826b4b6a6cbf474a6ee4ce0cd1bede87a2c8fe0d35397ddf6a4069437dd84
+DIST pytest-asyncio-0.23.3.tar.gz 44841 BLAKE2B f40f18e683ff1c6d905ae81c0a399655d461065f49fc862fe0d57c9d0deb14795e9792d76ea9759ea2b8736f7815de8c1778dbcaa8f477c59cbffd1f991e7ed1 SHA512 209a36de4d74bb3ade486b7c89c58def33b4aca84b3a096012d2ba329946f084a3f70489fb4ba0682e6acd65b6862e2ea4104a8e8912e8693f4f1685de357762
EBUILD pytest-asyncio-0.23.2.ebuild 1502 BLAKE2B 4bbf1e0e7b4ad35829ce587b367384cd3d5c0e170347f27d4d8948eea5aba4fde10b6bc2a79eab9f8dcf9c137bf3a3d4ea7916fd415839cc7a957670a6f59f5d SHA512 980b67811fc3596c910d51b520a971351d47e6813b42e08af4de32aa30a1417b8084d74c0c8cbac33352b8c55a2ff893a395f6fdbdf8a8ed310839a51e54da36
+EBUILD pytest-asyncio-0.23.3.ebuild 1510 BLAKE2B 079ea24bc853828c89b7347c7a5c15e42168b5de460968ba2b2015e7780c721b398ef7dcc247afa8154c3b3a214dfaa5372db0da9d6610101c5c87909005f51a SHA512 d3e92e0cb11d90853f8e73bbaa724214851a33f31ed8809e526d1e50db68626c0d63c979facf87cb47795aabec35719011080cea5805bb8cb8e7ec341b18b174
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild
new file mode 100644
index 000000000000..f54360ce4842
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.23.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/modes/test_legacy_mode.py
+ tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ tests/test_pytest_min_version_warning.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}