summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 21:39:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 21:39:30 +0100
commit78df2aa7ae35e69cd91f555197f771fcd59f196c (patch)
tree74b00805c302ea46f233ca348e39733649e52840 /dev-python/pytest-asyncio
parent3b882b15eed3bb219b5f340b63733c8cda643079 (diff)
gentoo auto-resync : 19:08:2023 - 21:39:30
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest4
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild48
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.21.1.ebuild2
3 files changed, 2 insertions, 52 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 7b45d43d488f..a991d5a6588d 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-asyncio-0.21.0.tar.gz 29898 BLAKE2B 6455e59a2e28ddbefd54e4c16970d36d22a674406fbc0e352e9886af3a7a51a0ae4a8ce32e01d076e2411f0501548092dfbe3150d87c14cb5e5eb71966bcb743 SHA512 ce557e5f15f3ae745804f4484d590a9f673d76f0c67c2e8ab444e1b17a4ae5ea6021bf55d7ef905643bfbcded6299f207a386fb4dc05ddf20ade25e6618a9773
DIST pytest-asyncio-0.21.1.tar.gz 30492 BLAKE2B 6a17f9ba89b8181b5fb734af6d0c0904a828156e63df910b4fe4adb9b93e240266063dcca8d97c8f9d784c6d5111796949fe32bb2832921919e41398ccffc155 SHA512 3aef14bade1dddab4320450d60c6909a76c7cf334d8225ad155b474b042d1c692edc5b567fb86ecf6b3453746105c3cecce86d2c6ff5cf6652d5147a8532cfd0
-EBUILD pytest-asyncio-0.21.0.ebuild 1414 BLAKE2B 52ad70e10c5d929dd424d5cf38122e1652704d30061cab0b7af8d85c5581a9847dd89e5b7bbe086739fedf54b0358f81f59b6a5e3a1b7c54e5b965f7de03413a SHA512 537b090ea69731af7cc1f8ae078898ad957f05f5a268b9e85c77c6e0cb2f5521ecb4bf155dc9a4e7a6e5375ca8a9587311578d7334cc0d7ffcdef16666abcd6d
-EBUILD pytest-asyncio-0.21.1.ebuild 1422 BLAKE2B bea4fa88e677d12627e6ad0586212774b71162329c46a6e4d7c71bf988a65dbb786154862bdce830e8f634a0864887870a089bfbe758622e3054c339e322ff20 SHA512 294ac7331ad6ff685dab0531560678b159d8e313069f5ae019bc70da44f47a00e7a3bcaff6b2be05712a52888ed6c76c4eb866dde09cdf2ad5ba4c7bcec8661c
+EBUILD pytest-asyncio-0.21.1.ebuild 1414 BLAKE2B 52ad70e10c5d929dd424d5cf38122e1652704d30061cab0b7af8d85c5581a9847dd89e5b7bbe086739fedf54b0358f81f59b6a5e3a1b7c54e5b965f7de03413a SHA512 537b090ea69731af7cc1f8ae078898ad957f05f5a268b9e85c77c6e0cb2f5521ecb4bf155dc9a4e7a6e5375ca8a9587311578d7334cc0d7ffcdef16666abcd6d
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild
deleted file mode 100644
index 95e4d0ec3e7a..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/test_pytest_min_version_warning.py
- tests/modes/test_legacy_mode.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
- epytest
-}
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.21.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.21.1.ebuild
index 9756a65aac50..95e4d0ec3e7a 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.21.1.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.21.1.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND="
>=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]