summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-asyncio
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild22
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index c99b1fc93363..698a88411924 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,3 @@
DIST pytest-asyncio-0.18.3.tar.gz 25049 BLAKE2B 5439675fd03b7fdd4cd3dbf1f37daa83d6b18b199ccc7b54acc648187dffcf59154f8f0ec5d4144ed40554290343a0890952e67d4184b17b0a3817196592023e SHA512 04d2046c039131598cb593afc1908be0dff2b24a91c89f36fca75d2d65916571e48fe149c1ba90244f299586277320cf6f130a02824fde9ee0a4d2429bf58a54
-EBUILD pytest-asyncio-0.18.3.ebuild 1027 BLAKE2B a093903a7e1a9948152705a8bf13d24b4c3832f7ef5c42ffae49a2eca27190191373925a8e038db8f3dfc3c08d54af1f20ffd09f2d735bd8c8d1363083095b39 SHA512 fb5571076e5cff853e3c272d820dc9c2169887da6ac81f0e49e14382797d8e259f451deabdff24d269b53923b74bdefd9bf5c961f30ff4a41ee947ac786bc084
+EBUILD pytest-asyncio-0.18.3.ebuild 1052 BLAKE2B 85c1564f05970dcba6d59feff8bb51c897e8c7e957808fce0d63bf4a2952281cd632cf80efa3c93d3ca2f5d27bf799aec22f2635594580fe3611ec7bc6e3d2a2 SHA512 5552d4f625cdc03ba219540c83ecc1b6d7d85a0d90a783a8b2906d04a8cdd04cf642c9117a822760cec827dd74af9b23934472e4a8814784530656d3094cdb35
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
index 886d7b984791..646385195afb 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
@@ -4,26 +4,34 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
- https://pypi.org/project/pytest-asyncio/"
-SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
dev-python/flaky[${PYTHON_USEDEP}]
>=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest