summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
commit750f865355947c40a4b93cd7a5db23eebc4e5080 (patch)
treed09084ef3a0baa1b4e6adbdbb4e85abc21f6650f /dev-python/pytest-asyncio
parentc51985271f4c8e0bc79728c6cecf15d6b6515914 (diff)
gentoo auto-resync : 08:12:2022 - 21:16:36
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 6073d886ea6d..997dc86b5ac1 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,5 +1,7 @@
DIST pytest-asyncio-0.20.1.gh.tar.gz 25425 BLAKE2B 90ab8ebdb854b78b0e910b26ffeab4841f0e6dc122bd8c12fa908a59e125473770bac553a8046be37679222016c204c83d9e01db27f6eca765fb3d9b6461d090 SHA512 994b942bc6452bd3972070d1eee3d88c6680a818ad38d6ed5ffa1faba51473227c838eaf24316c74479e7bb9faaf7fd3cbd1e5a07c2611f0e2eaffe369f75d95
DIST pytest-asyncio-0.20.2.gh.tar.gz 25876 BLAKE2B 75f948b804cb8945ec6153a5386ec4e2c5e95757c012acb04f9dcc877b109f0af1f9093a242c6d38196014c8da01fe459687d37fd4cb2fbeed2705936a9fba15 SHA512 5d8b4965cea14dec2a2c7f21f6bb1bad6693b93f07b9dab5c880107a944942bd2c3ef38adc0e17b309222a53afa7504f827baf42201c2a0282a266118e3f7eb7
+DIST pytest-asyncio-0.20.3.gh.tar.gz 27695 BLAKE2B 6e6f0d58d0f985cee9dc0b27f886d0b1b4b54ecbf4980c4ac59b420d6e6e5c01d1c6f3c9ed803391910124f19ee3a882c963f10e5f6bab6de6115bfa222c8be2 SHA512 78a6e251db80696d6f62a54c8d6836e2a820f27efdaa848eb1be512a1592d3bd3fb7c7eee46bb2039a317a8d431565614c888f8436fbe0d4eb60534ce4780e90
EBUILD pytest-asyncio-0.20.1.ebuild 1266 BLAKE2B 07ef6c8f5230733f60978d85277a8c58c071c9516c0b52da3481d7b821486641f5f1aaaa6abf7b6a0fe4d15d690d9965103d950861cea35062418e65310067a1 SHA512 3860304ac61c661a4acb52503aa9e3bd3d4af4232eb03f490f42ac9caaebf3a57d41d7ec5da7d280d8d2240e7506cc3dbae5123b93f22828274502c3e61484a6
EBUILD pytest-asyncio-0.20.2.ebuild 1274 BLAKE2B 8a3f8ca38d8eff67fee2d5bf0cc46d08e16aa96ac505a62a57defffb1c5beffef5174f1aad5f60d52ff36868d1c669d8a71e6793942eede089531cd4d00b3ade SHA512 5eb79e4f095bde563a4dafbc24db127b50c1bef8c036e10fafae9c1176416a26b5dc2d9954e1fb80a267ab71cac28b9bfc614f15fad175425f68a5a7e0b63d43
+EBUILD pytest-asyncio-0.20.3.ebuild 1274 BLAKE2B 8a3f8ca38d8eff67fee2d5bf0cc46d08e16aa96ac505a62a57defffb1c5beffef5174f1aad5f60d52ff36868d1c669d8a71e6793942eede089531cd4d00b3ade SHA512 5eb79e4f095bde563a4dafbc24db127b50c1bef8c036e10fafae9c1176416a26b5dc2d9954e1fb80a267ab71cac28b9bfc614f15fad175425f68a5a7e0b63d43
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild
new file mode 100644
index 000000000000..f52a6a0ee6c5
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/test_pytest_min_version_warning.py
+ tests/modes/test_legacy_mode.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
+ epytest
+}