summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/pytest-asyncio
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest4
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild26
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild26
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 4464ac5f9244..60ad7f4aa8ed 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,7 @@
DIST pytest-asyncio-0.14.0.tar.gz 14796 BLAKE2B 0a110dabde491293dc10452239971809ec6a4006a2036e848aac067df1af328d0d1d5c7afae8cfc1ecf5c919c0922050e2db182065500ec614a8094d3799c0cd SHA512 d1fadff152a0c94f80a8272a0dd293bd9d9300ad9e79c69556b5901c1a8ce00545f7715e503a383e3f4f35c8090d8f9ec33d16739b85378b59b1786a50441fca
+DIST pytest-asyncio-0.15.0.tar.gz 15555 BLAKE2B e9f0b732a1ff81c02cccbeddcebc593ceb982a640c5da2cf644ffc8e57548795cefdb7464bb1bb0d9a7d96a7476d30665dbea1c2b25341f8e71b16512c9402db SHA512 a936bd8f00cb470cee355b9abe6a6df5f65af5de9144bc0c128732f65fe4bc1e60b08a4e7287ae2f303e56e1764fd0bfe771102439e6d1ba7cb495d06b0677c0
+DIST pytest-asyncio-0.15.1.tar.gz 15653 BLAKE2B 8f10c46672a18d6992248482f9e3eb68ca9d3bae5163d5924e6363a15bc97dbfdc8b9dfc21a8a89ee4a6e21d76b083b1aa5a077fe581f0f2f0bd4c5a7b519cc9 SHA512 1813d49e0dd55f563d9bf058e009da61a17f61e081cc53626b5f1db623ba04905b6bea3ecba423dc931668053310176b634339d6526c7ea729d9aad87e4f044d
EBUILD pytest-asyncio-0.14.0.ebuild 818 BLAKE2B b8ea175fe0d697c82c573a8e145d14e8ae2a3a794ee6c2fdf401eb8eebc3e28c5ad02596665486a1600dcd76473b370b9b1496f669152670aeb11b7b27b651be SHA512 037f5979820fe4c719b008f36971723f32cf404d1397ae97df1950b7e04e5cd0360c56e0c3a635ab5b78ee66d8f17390427320bf67edf19fe4721054164bf519
+EBUILD pytest-asyncio-0.15.0.ebuild 691 BLAKE2B be3e79199410efd0bf4adcf98d36d936a745efeb0d1c94e3739f716268b6452143b5093036ee57100a86bbffe8fb25e94512d648a0b94617c9ca1cca0d601c68 SHA512 93fa2d0a8fbeaf821eb5b7ef01883d1b2b3e5ed5e267ce6f08bdb999362c6f3ba610e066f18b4318baf5328f7ae3ef8e294360ccf56fa4c9815f599dfb433197
+EBUILD pytest-asyncio-0.15.1.ebuild 709 BLAKE2B c3d533dc84f0122335bf125aa00eae185918a58ed08b53ba5cc0692b945d412a43225470cf32866877a85280c9bf7f18c1cb0c2eeef9dbd92aa9a128bd6d797d SHA512 b6eb2188610f231b9763021e3ea966837ec71512d3d42cc775239927b556744efd59927aee9994cf39ec16559c6bed884d3f52b0d587d5063b15dec8100532cd
MISC metadata.xml 384 BLAKE2B 72efae7dd0c314cd8f6e9e5b53fe94abab14fd591954474562ad4d6f5d485eaef9f324900cf79f3b857fb58e0b033ac496661e020ca9c88d2db0f1f8242d25af SHA512 ba2890b3bfba36b90098a578018c2fff627dd2537ac1c5dd90632c93df5a24a295050ef142caa5217d9a51da802aff686d9ea0318a1af7fcbc01e83b456848da
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild
new file mode 100644
index 000000000000..bcbcda7b5f7e
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
new file mode 100644
index 000000000000..60f1a55ba4e7
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest