summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/pytest-asyncio
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.17.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index d34161de0c5a..e3144b4ab2ca 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pytest-asyncio-0.16.0.tar.gz 15819 BLAKE2B c999b8680a45704bcb6f4690a910aa3d2edd9965e53cf4eb59dc8119696add4553d6b3e1b010c3cac52c8fd8563be8c86afe0616132a274e73df673630b032a7 SHA512 f0059a6d05bf0c4e208f0058e30d5baf8284e630b8b91fa217f52eec18abe6b057dabfdadce2c5282e02bd4ea4cdb27f9ef62c4c308375cce1795d75a036db22
+DIST pytest-asyncio-0.17.0.tar.gz 22275 BLAKE2B 0151b7e264b2c2435735bdc184020b6997d20b0ed82224b0b528ec366ab7554a0282619c5268d92f2544d700bed2dbaf85adaaf1752e333c417cc044bffb6aac SHA512 cfff79cf0632153819c511d3751777858e87081b074bfb49f3fe49417d1be647b4d07a4b64149acec36b4e6b1872ac03f1055703c70cccce18648482c9b727db
EBUILD pytest-asyncio-0.16.0.ebuild 715 BLAKE2B b02ffaf3af6a84598a95cd09e6186d733efb51ddccf77bf496c6b65c0e761fae0336aafa99710bfa6ddab4f654175025318a82ec17bea6f4369efafda992bdc5 SHA512 cd249bc7eeefcc1e98c2332a284965c68341a181f38c2c32ea7ed1cb5aefe3cc8ec8c4376cf9e88fed9e1165ef91ef38b0ae868732e9cf4cbec8de21017ee6f2
+EBUILD pytest-asyncio-0.17.0.ebuild 939 BLAKE2B 2c13ae8d2c708f4077f368084cd9ac818260cfc989fc462e9a97be9080dbbb4f8e383fa5233a54e22dd9d5de69e3b79fdbd965cdef8cbb1800f7e6f43a4b01f9 SHA512 2584443b8e72f04ae45585ea4356c33b8f83053b9ed2e6e99c81b1fecbc7936f5a9fe08c3636b0c9cbe28e74d95b3cb7f0803bf205f764acbfc82d8e7ad0aac7
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.17.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.17.0.ebuild
new file mode 100644
index 000000000000..eba2bcf7d5c3
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.17.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/modes/test_legacy_mode.py
+)