summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
commit29607d91fb1bf1c4456a0b90601ee172ea769283 (patch)
tree71a1c87ff8b0a522d0f8243a4f064f8f9b5d94e4 /dev-python/pytest-asyncio
parent22b96ae0ceb12f57b30fc2577770f565506bbac8 (diff)
gentoo auto-resync : 16:07:2022 - 13:45:35
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 698a88411924..a9082db0e72f 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pytest-asyncio-0.18.3.tar.gz 25049 BLAKE2B 5439675fd03b7fdd4cd3dbf1f37daa83d6b18b199ccc7b54acc648187dffcf59154f8f0ec5d4144ed40554290343a0890952e67d4184b17b0a3817196592023e SHA512 04d2046c039131598cb593afc1908be0dff2b24a91c89f36fca75d2d65916571e48fe149c1ba90244f299586277320cf6f130a02824fde9ee0a4d2429bf58a54
+DIST pytest-asyncio-0.19.0.gh.tar.gz 25754 BLAKE2B ee1e028021d7adaeef77e9dc9c1cc0d1a8fe5ee91777b2774d8f175e7520f7f1ae6d058d758964a052d2fc02d369a9dcb522edf8271b54b9b724555222592e29 SHA512 7be87e6edd28496713ae5cca396fed67d372f2882dd573a8b72a84ebf6d262060cda9372bcde601130c42fc27faf15cf292cd820995ea93a324c209f203e823f
EBUILD pytest-asyncio-0.18.3.ebuild 1052 BLAKE2B 85c1564f05970dcba6d59feff8bb51c897e8c7e957808fce0d63bf4a2952281cd632cf80efa3c93d3ca2f5d27bf799aec22f2635594580fe3611ec7bc6e3d2a2 SHA512 5552d4f625cdc03ba219540c83ecc1b6d7d85a0d90a783a8b2906d04a8cdd04cf642c9117a822760cec827dd74af9b23934472e4a8814784530656d3094cdb35
+EBUILD pytest-asyncio-0.19.0.ebuild 1232 BLAKE2B de729ab12097ea826c305502a72046fb2676c4b64fcc684886998bb5dcf71faeac67b466ec960bdcf71f75088e3c6f8a1f97d62969cb4e1bfffe2be96549891a SHA512 465302dbfa11eacfe7e1633abb366d06376fef15299d9b84bd9440603a3bd8d4f34990aa0dc905847c14c605ff606fd095e055154486479d55db6820209963a9
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild
new file mode 100644
index 000000000000..b35be0f8f03e
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/modes/test_legacy_mode.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
+ epytest
+}