summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/pytest-asyncio
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild10
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index e29316569f90..e75940c5412c 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,3 @@
DIST pytest-asyncio-0.10.0.tar.gz 13968 BLAKE2B 4e63d527b20c767b8f0777ed684a15abe54009be72db8a50ca3b37ef95dceb884168d8081c651e2bbd6d818529d6809bb3498055fedc7f951f5675d58f50e408 SHA512 78160d1918c5d3d2172f74fa07bf4bf6d0bc416666011dd5b83b3a7f385ec30fc65d49c01bba5dd0e16ad9dcd9d72d8ab062526f3268d60cd2e24a35b5a8f883
-EBUILD pytest-asyncio-0.10.0.ebuild 949 BLAKE2B 945bbebce007188839da358423aa11318088005a71d873cd4c223d83e0f99d0b2dba7db9bf8f8d6561de03ec144ae6320e407379df4755c191888c4d819f8b24 SHA512 9311b00325bf02b1ddb51925f1a3732b32db6d61ea4e95edf5293322f7637f95c81bfd3f5cb110ad7b7e0dc720061f784d4185b80579cf2cbf978e7f35ad1e4e
+EBUILD pytest-asyncio-0.10.0.ebuild 874 BLAKE2B 910870dda29a0722a1cc51032172c2e24f2af151e430fa33fef3e78222e97a629bf192a3e0c1c94173f4bf962fe50e4c9cba85344e9f2b31230feb35f2393870 SHA512 061ccc2f757cf6afd6924ec87d384becfaf36bddbcaef37d3f25c627ae4165f3dd18324fe83fde4d82f8e0a601e9d2a3a3bb8ab96813776901665090c03d5dca
MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
index ee183d8b8079..9e9d67138cb1 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="Library for testing asyncio code with pytest"
@@ -13,15 +13,13 @@ SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> $
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/async_generator[${PYTHON_USEDEP}]' \
- python3_5)"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}