summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-09 12:44:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-09 12:44:17 +0000
commit20d4435a7d9459953db77f3256f699f420d3e484 (patch)
treeb948635f8c8917e2c046e2dac66b3b25c2606317 /dev-python/pytest-asyncio
parent4464bf26d93bdcc80e0b1330fe9c9caef26b34fc (diff)
gentoo auto-resync : 09:03:2024 - 12:44:17
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.5_p1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 34fa3ac6a893..af0f4872c291 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-asyncio-0.23.5.post1.tar.gz 46227 BLAKE2B 25c1ea816efee026ffec8703a3f8d84311e67a73e5c32395aa0b5dd9ee9b328c0eb198ee64aadafedd9f1563dfe8074720059f536a998cddc45c7b85e8d7f251 SHA512 a8948f82d281d760bdd55b4fb84dc72ff6a8fcb813896d1c9024586c1aac52b5f18831599f6b5160f203ac35410ad8286c06242ece63d7eb728b89e66ca82855
DIST pytest-asyncio-0.23.5.tar.gz 45887 BLAKE2B 6f641d3c614c5a224f51278ba6021ed40f015a30aa19999cca7803cc3b50e91e8a0e3c997fbd6905801a10fda5f6c2de9f2ce3228d6f1a3f734e81ebd9f0796c SHA512 112ddaa0cf8c05cec4e99cb55df4db1b7d9929b13aa531172b442cff4cd49fbe12ec23ff12aaa260f303919c840c13b21c00a94990e4b107fb115c4850a33b47
EBUILD pytest-asyncio-0.23.5.ebuild 1605 BLAKE2B 06b9821bf10e8071302d96eefef1ae5ee1abb01fd22324409e4fe118dc2cb93768b2e0a48ec29596d95e20ab37e89f9aecc5f6911a54c84c8ba980e70b97d99c SHA512 5645c0a2addeecefde1b1d1d163ac0b1ef5025dc92a6cd26f92530b1642d7677b77cd97ccf57e20ce9ae9b6daa773701805686bd60eb5722e0727d8e8aab1ec2
+EBUILD pytest-asyncio-0.23.5_p1.ebuild 1613 BLAKE2B fc7729d1a0392ab2ef98bc82056511444fc4d83fc9acfdd993ad81291ba40f3fee346442370c6a2f32267ec33de203db7e0632e1b158d2919f18aefb0da44437 SHA512 5b3c5e36c5dfa25a4ae5d918d6d52f7df29f8a005012f437d52e2a53e12495ad7eb5b39f413a97f521605a5ba57d5ad91037274a1952c6ea91cd0942155f9a57
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.5_p1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.5_p1.ebuild
new file mode 100644
index 000000000000..3309bf08c6f5
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.23.5_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/modes/test_legacy_mode.py
+ tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ tests/test_pytest_min_version_warning.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+
+ # TODO
+ tests/test_is_async_test.py::test_returns_false_for_unmarked_coroutine_item_in_strict_mode
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}