summaryrefslogtreecommitdiff
path: root/dev-python/pytest-arraydiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-arraydiff
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-arraydiff')
-rw-r--r--dev-python/pytest-arraydiff/Manifest3
-rw-r--r--dev-python/pytest-arraydiff/metadata.xml15
-rw-r--r--dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-arraydiff/Manifest b/dev-python/pytest-arraydiff/Manifest
new file mode 100644
index 000000000000..7c01ef9f142f
--- /dev/null
+++ b/dev-python/pytest-arraydiff/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-arraydiff-0.1.tar.gz 8752 BLAKE2B c8d262d38aff61b5559f33786bf7cc396bda8dc30789ea349f9955a12722e10f6b48ae862cf6fa526da85e4c52b6b68339d18d0be088e1f831c05fd57becccdd SHA512 321ea04ea7165753cb4d9aff3870d5297f78a0e5ddaf16aecd5dce622f061a2f664479bf8e3af1c7575e968fa66828ed2d0489473e7d8a236c07d1a31adfce5d
+EBUILD pytest-arraydiff-0.1.ebuild 645 BLAKE2B ad2a45c1ec04d55d647b196270921259e1f89d499efb0bd113ced8c7038c6176024ff918dc6a31d30355cf96269f6439ddf4ecc6d19a9c8309b39223953a03d7 SHA512 88cd6df1f21257b6a92f235068ee508501014149bff17207c0a4d2a54c3b3920a176f4d03a49c94206d1eec6f1bcd06f3e97dbf7aa3108e828750a006d0372e5
+MISC metadata.xml 527 BLAKE2B 47c322c71573827902b8c93fa33d92162c61a31f4764c68f62754296c52929397db1bd7c70a7baaa96fa203adea26ce954e0ca985c799f2f9300c5bcbc122847 SHA512 9138033364e009d0bef6499aa1f5353a72033955df26a26869038783bf847c91e8ebdc1b62908e393c4471285420ddeb01118aff5905227b67aeb924bdf2738c
diff --git a/dev-python/pytest-arraydiff/metadata.xml b/dev-python/pytest-arraydiff/metadata.xml
new file mode 100644
index 000000000000..a5905e0e3a81
--- /dev/null
+++ b/dev-python/pytest-arraydiff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-arraydiff</remote-id>
+ <remote-id type="github">astrofrog/pytest-arraydiff</remote-id>
+ </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin to faciliate image comparison for numpy arrays in Pytest.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
new file mode 100644
index 000000000000..4220d94ae372
--- /dev/null
+++ b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DOCS=( README.rst CHANGES.md )
+
+DESCRIPTION="pytest plugin to facilitate comparison of arrays"
+HOMEPAGE="https://github.com/astrofrog/pytest-arraydiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"