summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pytest-aiohttp
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest4
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.2.ebuild28
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild28
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index 79c9cdaa42d5..2dddddfe489c 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1,3 +1,7 @@
DIST pytest-aiohttp-0.3.0.tar.gz 6884 BLAKE2B 02b50fcd14192d23a4b257c2b7cb235966eff52b1c0ac87a4c61a20bc0babdb22eb999938c63e267a797d52ce57c9fb471232db3d0bc6566168a2d73f6404cd4 SHA512 4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c
+DIST pytest-aiohttp-1.0.2.tar.gz 11102 BLAKE2B 3210b9ebb9c7e55e182595187bb17ad55acf28439750e8424004a1a33008fc62d6be26959f5d2c8db8659d9657c57e6a7b154fb1286cb6e034f26cb8c377e27c SHA512 3bab3df10ea5642c183681d2a6a70a842f1c11f0a6907334e04a528383051243cf7013548406fcc53525f9003fa536a92a45a97f7d54466a049afc4c579780e5
+DIST pytest-aiohttp-1.0.3.tar.gz 11155 BLAKE2B d539b69145944458ffd18f66d92117b5cf2c3d67664660086e1f585ee089dfc85b6e605ce8c8dbe75f974c16a6ad743f46cfb1e4bc19d68e4bf04a3be65ed4fd SHA512 5d900875fd2973d7ca578d9787a6cf1e3cc6f9ae85b81e83f141c1bd2f789b55437769f2e2ebf50d424979ff4f199a73cbebd171e78f21133423476409422805
EBUILD pytest-aiohttp-0.3.0-r1.ebuild 547 BLAKE2B 5c088b47cb2a0a3ca328b6cecc11fab293f2ed3fdbbe2cc5bc8ca799cf0a3ce2d883eeee31b08a77a16f66bcce8549d2fed1dd183426a79db594e437a1fb5b68 SHA512 244e0586f80244ae61d860c521e0c92db70d8297c5e04a58c42f5747d79165b24575b94bc879da5c50cd0894afc50223a9feb5cdc5a34540d7cbe79068684d1d
+EBUILD pytest-aiohttp-1.0.2.ebuild 736 BLAKE2B d719ff57e3deb27f99b49db05754a4bcb0606308636717d5a58e0a730c80caa36b80f632dc5f18bff9b192e277c8afc5f67290daeb5c9e414130d235173bb42e SHA512 a7d2ae46cfbea865838d2b2ba231de789c13dd89058c6b82879d69e43f2b8479f7a90c3f516061d9f7a648b5b40ffdf1df27222a715694a925b244aa08ebb20a
+EBUILD pytest-aiohttp-1.0.3.ebuild 736 BLAKE2B d719ff57e3deb27f99b49db05754a4bcb0606308636717d5a58e0a730c80caa36b80f632dc5f18bff9b192e277c8afc5f67290daeb5c9e414130d235173bb42e SHA512 a7d2ae46cfbea865838d2b2ba231de789c13dd89058c6b82879d69e43f2b8479f7a90c3f516061d9f7a648b5b40ffdf1df27222a715694a925b244aa08ebb20a
MISC metadata.xml 383 BLAKE2B aef07c31a48de61fffa14c250aac7d1de63b652f94d83c52d32df2100da3bc5be19f224078b1b984520cc7e0b3d80838379388aa4c0e9531317a79dca178370c SHA512 b73d692782a9eae48022738bbcf3771605c8d00bf73ab2499cc27f309069bb80a402cd1ce618df29de7dfd11c226514aa3ec7d78df1ea784c7221691febf06f9
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.2.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.2.ebuild
new file mode 100644
index 000000000000..6f2f5b8373a9
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild
new file mode 100644
index 000000000000..6f2f5b8373a9
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest