summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pytest-aiohttp
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest1
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index 0561cfdb5fa1..f51c3edc409a 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1,3 +1,4 @@
DIST pytest-aiohttp-0.3.0.tar.gz 6884 BLAKE2B 02b50fcd14192d23a4b257c2b7cb235966eff52b1c0ac87a4c61a20bc0babdb22eb999938c63e267a797d52ce57c9fb471232db3d0bc6566168a2d73f6404cd4 SHA512 4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c
+EBUILD pytest-aiohttp-0.3.0-r1.ebuild 616 BLAKE2B fb52e1e2387c48a827b69c4e961eeba23e641f8636ef336a785b53a6cad3a196358d713bf70bf977d244aa7dbb84dabfcedf3f1b0e0ae5a665eb37109a54e8a1 SHA512 1cd7d534b77903382de1441d298317e54f4bbfc620f07f4bd402a24555907c0212eb6b3583e9650988607d71696f350d2bf7ed2254e0ff6cb018be8a98d6f653
EBUILD pytest-aiohttp-0.3.0.ebuild 608 BLAKE2B 15c3fe584a822ae28da6b01f91dbeb89b9fb7e2691164d585c4072128671289dfedce1b9e4dadad83342a18c7e2ce89ff4effc77e525d9ef862fb5109299974b SHA512 40409add5aacf9f266d658cff98be13321e4540f0dd5f367f9f61db4ea6078c8b834e6e1d024ee85d90d94afff48a7d071a5e4759d0451fd40690a2c16a20ea0
MISC metadata.xml 358 BLAKE2B 8d7d3a4d56967f16b3c8b5facccb0af056201daf975aeaa8cb9b651db735183cb38e35d1a86037306d6c61971690b7093ac8bf0c4197b2ce6228d0323c15ed0d SHA512 4f7db25811be35ac9976bf5707b0ee0927dae9f00d8be85f18eb165708f08ec7c4bb7ebfc4ca021a6432eab8ab25785c8b27959df8ff9dfc2a969b588de68829
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..733b6f0e1963
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"