summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 22:26:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 22:26:54 +0100
commitb50dd652d8e73a93ecd53b7520f2e841a05911f0 (patch)
tree4bc388dbb23631151ca68bacfd264f9ccbf89006 /dev-python/pytest-aiohttp
parent3221bf225fb68a31e281fcdbfde4cea0d576d946 (diff)
gentoo auto-resync : 06:09:2023 - 22:26:53
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest2
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index e69b9206e5fe..0649de095546 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1,3 +1,5 @@
DIST pytest-aiohttp-1.0.4.tar.gz 11868 BLAKE2B d964fe29ebe10e80391ebcbe4fc73bf37e2d8568c4d7679493ce68392b5722d75735798a78f388134d60b9c922bac116b0d453cabae5a95fc06c4288cc5d4c8e SHA512 baf87e3aa229e8a4ab6746d277a923436ad2e0625825581c94a2fb0a9bbcd309bfc55186f8866589b65a75ccfd7d5b494d71554359724c0b2c9541ea94a177d8
+DIST pytest-aiohttp-1.0.5.tar.gz 12209 BLAKE2B b02154239a6073bafac3d8be70a7ae8ff13fefdd09941db558c0b1ad31d14c5e29131209f157ab418202852a2d97f151d765cfffe0de06aac57f0c983ea99518 SHA512 b8421c63e4d5caa9742a013a6d1fd3c010b5e4a48e4f5c1a07ddfb7b05853ce6a7a0d65ce78493fd607f59c669d31c75d97a9022048e6a60cbc90a19a48dd02c
EBUILD pytest-aiohttp-1.0.4.ebuild 920 BLAKE2B 2c3704197ef0f9990aef39e59436379086b00b21b8b8ce8219fdcda4012756400761df55a9d4464115e9d4dc8a146abaa73e71267b755f352341521d7f6f82ee SHA512 30836ccf67b681beaf9d9aaa086c171460d45cfcca326bac54ef69fe584c7049fc989e703aeec92401647f762c2ef7a8f3f0f6a2e692c13236268d5852d96b49
+EBUILD pytest-aiohttp-1.0.5.ebuild 928 BLAKE2B 9c7a96b416ec0aebfbc24cb79d8ca701303737cd79dc782334dfaa1417d711ee0cda75285f2bb709945979ad993e02025f390f3b1ab0cc6dbfbacb5f180f4261 SHA512 f66d40827ee45f389202b8b2de1b7ad7b38d0bdc3a41a42d762fa155a9ef27f5dae8a349c700ca4bfdd5283534a51aae917e687493078c6afdeb857b5d370f19
MISC metadata.xml 383 BLAKE2B aef07c31a48de61fffa14c250aac7d1de63b652f94d83c52d32df2100da3bc5be19f224078b1b984520cc7e0b3d80838379388aa4c0e9531317a79dca178370c SHA512 b73d692782a9eae48022738bbcf3771605c8d00bf73ab2499cc27f309069bb80a402cd1ce618df29de7dfd11c226514aa3ec7d78df1ea784c7221691febf06f9
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild
new file mode 100644
index 000000000000..a3fd0d0ec5f8
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="
+ https://github.com/aio-libs/pytest-aiohttp/
+ https://pypi.org/project/pytest-aiohttp/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning doesn't seem to be emitted for some reason
+ # doesn't look very important
+ tests/test_obsolete_fixtures.py::test_loop_fixture
+)