summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-aiohttp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest5
-rw-r--r--dev-python/pytest-aiohttp/metadata.xml11
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild24
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild24
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
new file mode 100644
index 000000000000..2e7a12d70cc5
--- /dev/null
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-aiohttp-0.1.3.tar.gz 6192 BLAKE2B 23f4eebdefe757328fc8621e29810835fee8e8c3e8cedf45134716cff77208bcd7aa82f537ada5d567b143d342b1a9fa14a5ed1e5208548e55353de1748b270c SHA512 2271f7730b91812a619e04522c13b7e2ff76353179a4588226d0b943b67f7397b966c1d3c24016861cc3eda3a541b3f0d3b2858a6ca3586f7707e10581c34e4c
+DIST pytest-aiohttp-0.3.0.tar.gz 6884 BLAKE2B 02b50fcd14192d23a4b257c2b7cb235966eff52b1c0ac87a4c61a20bc0babdb22eb999938c63e267a797d52ce57c9fb471232db3d0bc6566168a2d73f6404cd4 SHA512 4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c
+EBUILD pytest-aiohttp-0.1.3.ebuild 567 BLAKE2B c15a0ee1a882674356eed783e6b48bbe45a04af0a2c43e4be3190f3c11aefea95496308b6431c80590998649569fbecb4bad5f9e37e515c95aa57e7b8b251cfa SHA512 5c8d342844f8db2ef4281f113904e97f07f9900189c608db57298686a61c72db6e49e9277d9c4581d74cb41692893569ee8f61269af44aecca0a7860eb44e9a6
+EBUILD pytest-aiohttp-0.3.0.ebuild 567 BLAKE2B 933065f92b863dd6b81565ecf415b00a87f1270bafa8337e9df654f71c1d9bbc2e5bc4a3f0fd067c36ea792f01c5d24365fcbaa499d46c01ea6a61d486e7a6b1 SHA512 9b3f76e6d28698cef1ce40ab4ab949d8d4aa2149d91e39086c8aef1a6cff826c342f84a2f3eab7df0d3870134ac3ec4c4b150706b10d7a7dbce096bc0fec6d23
+MISC metadata.xml 358 BLAKE2B 8d7d3a4d56967f16b3c8b5facccb0af056201daf975aeaa8cb9b651db735183cb38e35d1a86037306d6c61971690b7093ac8bf0c4197b2ce6228d0323c15ed0d SHA512 4f7db25811be35ac9976bf5707b0ee0927dae9f00d8be85f18eb165708f08ec7c4bb7ebfc4ca021a6432eab8ab25785c8b27959df8ff9dfc2a969b588de68829
diff --git a/dev-python/pytest-aiohttp/metadata.xml b/dev-python/pytest-aiohttp/metadata.xml
new file mode 100644
index 000000000000..947779f0a967
--- /dev/null
+++ b/dev-python/pytest-aiohttp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aio-libs/pytest-aiohttp</remote-id>
+ <remote-id type="pypi">pytest-aiohttp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild
new file mode 100644
index 000000000000..e0262e7f2199
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild
new file mode 100644
index 000000000000..4c9076789a98
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"