summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-aiohttp
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest2
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild13
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index 30448b9afef3..cfa6cb614c49 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1,3 +1,3 @@
DIST pytest-aiohttp-1.0.4.tar.gz 11868 BLAKE2B d964fe29ebe10e80391ebcbe4fc73bf37e2d8568c4d7679493ce68392b5722d75735798a78f388134d60b9c922bac116b0d453cabae5a95fc06c4288cc5d4c8e SHA512 baf87e3aa229e8a4ab6746d277a923436ad2e0625825581c94a2fb0a9bbcd309bfc55186f8866589b65a75ccfd7d5b494d71554359724c0b2c9541ea94a177d8
-EBUILD pytest-aiohttp-1.0.4.ebuild 741 BLAKE2B ffb05228ccbbc706c86e5a527a7f499bdc50bfa43291cd9964bc363ce27599870c0c208be45038a5339ea9782af091558f6a76029a75de386aef64812ceebcaf SHA512 853a152696e5623ebfb3b8429db95b300c60c9ea95c1e97a927cf02e23184bf5ca49234949a653ea828484fddc5ed441c016f81faa97c167c92aaa9d718acc98
+EBUILD pytest-aiohttp-1.0.4.ebuild 945 BLAKE2B 66b346075f6f32cee1500badd491f43591abe55e99b34445f5d42cb7e3b5c95e414ab73b6987e3c6f25e5b5b745d0fb4157e500de63c7415cf0a994d9298c86f SHA512 2dbdc85b2cc6e9e2733e2e54b49e93ff71da5b77d5e758101c84e7b3299db2448fd54fd22a190a1f4cbed219ff6fc96468258033560a5aec1aeaf540df73a349
MISC metadata.xml 383 BLAKE2B aef07c31a48de61fffa14c250aac7d1de63b652f94d83c52d32df2100da3bc5be19f224078b1b984520cc7e0b3d80838379388aa4c0e9531317a79dca178370c SHA512 b73d692782a9eae48022738bbcf3771605c8d00bf73ab2499cc27f309069bb80a402cd1ce618df29de7dfd11c226514aa3ec7d78df1ea784c7221691febf06f9
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
index 1ad54bae78d3..d009d00e3de7 100644
--- a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="pytest plugin for aiohttp support"
-HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+HOMEPAGE="
+ https://github.com/aio-libs/pytest-aiohttp/
+ https://pypi.org/project/pytest-aiohttp/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
@@ -26,3 +29,9 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning doesn't seem to be emitted for some reason
+ # doesn't look very important
+ tests/test_obsolete_fixtures.py::test_loop_fixture
+)