summaryrefslogtreecommitdiff
path: root/dev-python/pytesseract
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytesseract
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytesseract')
-rw-r--r--dev-python/pytesseract/Manifest3
-rw-r--r--dev-python/pytesseract/metadata.xml23
-rw-r--r--dev-python/pytesseract/pytesseract-0.3.10.ebuild31
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytesseract/Manifest b/dev-python/pytesseract/Manifest
new file mode 100644
index 000000000000..7fb9b0a971ef
--- /dev/null
+++ b/dev-python/pytesseract/Manifest
@@ -0,0 +1,3 @@
+DIST pytesseract-0.3.10.tar.gz 1098547 BLAKE2B d89f9082d8c7236b97bb96441809a19f494aacd23d4c02d5b7fb1b742616e7b26c249d49fceecc4f652792cdc3d7f2a79cd580a3360157f81205ff04d65afb10 SHA512 de77f0497c2bf60c1febf439ed13f0a8978aa23df76aadb789f8151177b73f45229799bd6b236aa7356a5145064f892e5b528a2d5a396849348f5b22f4343e16
+EBUILD pytesseract-0.3.10.ebuild 693 BLAKE2B f161c38a7991ea86b3b558eee512621c86d04280b0a3b068e1ae1db98901d167b9ddc738504994bd989588cbfa3c761cfa1c6b0f60110dbd94beef4ebc761bb7 SHA512 8569dbceaae585d5ee80da753de4bbbc4145b5ef29d280145688ab9296e11e2c683c1571075f437d5d0cf4d3c91ada4f271fd81948373ee477123d24d48b3121
+MISC metadata.xml 928 BLAKE2B 69397ac26f64a9c741e906d4ff1f105319cd5baa00ca5bebac019f2f2d0e2f55f6ddb4e55e54f068da58663cef00923b423aa13a460d21c5701d088a97f7b52b SHA512 d566881fe46eae8c9d86bcca464f718db30f7bda710d58acc6563920d07cdeb3be727980dcf1611b3653c9c8ca0b60fb01584efbf84c4b9f9e0287d8db760bc8
diff --git a/dev-python/pytesseract/metadata.xml b/dev-python/pytesseract/metadata.xml
new file mode 100644
index 000000000000..2f762d632807
--- /dev/null
+++ b/dev-python/pytesseract/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python-tesseract is an optical character recognition (OCR) tool for
+ python.
+ That is, it will recognize and "read" the text embedded in images.
+
+ Python-tesseract is a wrapper for Google's Tesseract-OCR Engine.
+ It is also useful as a stand-alone invocation script to tesseract, as
+ it can read all image types supported by the Pillow and Leptonica
+ imaging libraries, including jpeg, png, gif, bmp, tiff, and others.
+ Additionally, if used as a script, Python-tesseract will print the
+ recognized text instead of writing it to a file.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">madmaze/pytesseract</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytesseract/pytesseract-0.3.10.ebuild b/dev-python/pytesseract/pytesseract-0.3.10.ebuild
new file mode 100644
index 000000000000..4fa1103fcf5a
--- /dev/null
+++ b/dev-python/pytesseract/pytesseract-0.3.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Optical character recognition (OCR) tool"
+HOMEPAGE="https://github.com/madmaze/pytesseract"
+SRC_URI="https://github.com/madmaze/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ app-text/tesseract"
+BDEPEND="
+ test? (
+ app-text/tesseract[jpeg,png,tiff,webp]
+ media-libs/leptonica[gif,jpeg2k]
+ app-text/tessdata_fast[l10n_fr]
+ dev-python/pillow[jpeg,zlib]
+ )
+"
+
+distutils_enable_tests pytest