summaryrefslogtreecommitdiff
path: root/dev-python/pyte
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/pyte
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyte')
-rw-r--r--dev-python/pyte/Manifest2
-rw-r--r--dev-python/pyte/pyte-0.8.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyte/Manifest b/dev-python/pyte/Manifest
index 75e4ee8b88eb..6c960d0658e8 100644
--- a/dev-python/pyte/Manifest
+++ b/dev-python/pyte/Manifest
@@ -1,4 +1,6 @@
DIST pyte-0.5.2.tar.gz 42719 BLAKE2B 00995c8427ade8a44dbc6dea4bea058431adb1409fbddc90b70ecd3cf4968632d66e4f21140ca5c071ea927208d40ed55606cf2d604f931970f99128c2b2dba8 SHA512 da903b31bb67e60bc8271c162f3429871d0def039cec5f63f07764fce1994236063876eb069a88783a4c7d8b0eac0646549c00f2a51ab8630287d852f05f4b0d
+DIST pyte-0.8.0.tar.gz 50415 BLAKE2B 8e707d8dd598d4b76b281de1481d238448f6ed07daa962647e61e7f5ad62da67a08112db7e21cb3522e5719514975a9b01ec06ff1cf2222590e02d9ff434369e SHA512 b1c23206f32c49ab509ac9bd4e042b043478cae35594c52c8389f5a5ba15cd0895315c42be5a0f2992b3aaa918ae282e43e88e72798a0b600307860f6df06465
EBUILD pyte-0.5.2-r1.ebuild 757 BLAKE2B 8a3c216c4a31ee995dafc5cb11213baae2094cb3ed6c5b50345b0613e044c4b6547483fde977fdaeffea3f999af4e1dfbdd5a17e42ec6876dfd514dd022fbb09 SHA512 ffbcd7f8e159db786761465cab044f5c7a6153f5b290e6a3fda9f63933f863e0bcd45df5035b164304d60926a6fa267e4bc6f86f3e4ae71356464d46e3196f1b
EBUILD pyte-0.5.2-r2.ebuild 759 BLAKE2B fcda9ebb7649244705f385f21dc4173d45679aa2b2f376bc3fe74f60bf3f14eb9b3ce74eb7e6defd94919dfc7b69aebc8f3592cc53f731d353f774f218af1336 SHA512 cd4d6c4012b520576ff16ee2d8c016be3cb293f7400216324dfde8f478683be9a539fa7bd2f919d6fe2cc858581e60acaaa20eff7214d325b997c4e7f9fbd881
+EBUILD pyte-0.8.0.ebuild 761 BLAKE2B 619ab3b0a41964ef52abe18c63ee85e0c88fd9189837b286a1a722beb3d80c8c52afe8d8ab32bc774d4d5fb5843081bb895d35ed49f14774670b421cc28aefd1 SHA512 acd80900683699b649cce4705d9b40b4cb1ac9d88a77abbe1fa7c305a4caaca406754db7eb7ca756f2204dd2328bc9e55596fadde17e2953941d77a4fb617abc
MISC metadata.xml 372 BLAKE2B 6e2290ce2905925561a7bb3bd42f754191dfa28b2bfe493d234e3944d9b80e1b7c28440105a95e0e31ba0d445979c235683c81b4ee4cec7930809a6ef6fb7cb4 SHA512 6ba189a1a43ff10537319bfdebf23046437a86dec5c6bb219e97076120b31e20aba0e4cdb8abe932c378d17c766ae2ae7a65d9538cf3926cb106bd20206901bc
diff --git a/dev-python/pyte/pyte-0.8.0.ebuild b/dev-python/pyte/pyte-0.8.0.ebuild
new file mode 100644
index 000000000000..7de14fd4a96d
--- /dev/null
+++ b/dev-python/pyte/pyte-0.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.org/project/pyte/ https://github.com/selectel/pyte"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test --verbose
+}