summaryrefslogtreecommitdiff
path: root/dev-python/pyte/pyte-0.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-python/pyte/pyte-0.8.0-r1.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-python/pyte/pyte-0.8.0-r1.ebuild')
-rw-r--r--dev-python/pyte/pyte-0.8.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyte/pyte-0.8.0-r1.ebuild b/dev-python/pyte/pyte-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..d2401d461ce0
--- /dev/null
+++ b/dev-python/pyte/pyte-0.8.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.org/project/pyte/ https://github.com/selectel/pyte"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# use github tarball as pypi is missing test data
+SRC_URI="https://github.com/selectel/pyte/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # run pytest directly for tests
+ sed -i '/setup_requires=\["pytest-runner"\]/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}