summaryrefslogtreecommitdiff
path: root/dev-python/pyte/pyte-0.5.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyte/pyte-0.5.2-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyte/pyte-0.5.2-r2.ebuild')
-rw-r--r--dev-python/pyte/pyte-0.5.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyte/pyte-0.5.2-r2.ebuild b/dev-python/pyte/pyte-0.5.2-r2.ebuild
new file mode 100644
index 000000000000..999ffe7479b7
--- /dev/null
+++ b/dev-python/pyte/pyte-0.5.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.python.org/pypi/pyte/ https://github.com/selectel/pyte"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test --verbose
+}