summaryrefslogtreecommitdiff
path: root/dev-python/pysvn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 07:19:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 07:19:33 +0000
commit0bdb5244708888dfc364e30b08facc0a45281f78 (patch)
tree85a5d103ddb3f2e1434b2a741a77626999887328 /dev-python/pysvn
parent56767705335e747c2a8b3f3282e5c1a393352d54 (diff)
gentoo auto-resync : 29:11:2022 - 07:19:33
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/Manifest3
-rw-r--r--dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch33
-rw-r--r--dev-python/pysvn/pysvn-1.9.18.ebuild66
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index 293b07b8ae5e..1bda24b8b050 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1,3 +1,6 @@
+AUX pysvn-1.9.18-tests-3.11.patch 1031 BLAKE2B 3886df331cbacedb7046b78a914b29cd65dd52854a12eeed91a83cd18997d2d8887ab099576b35f98f200d5a4bb726b38f155b9df36b7f8d676dd470962a6012 SHA512 ec1e83e905f0e1e0666e01d8cdf688c0fc04cef4a4e222b92abcdf777f7ed7884c68a742676cdc2f4642731d5d0a8abc5ca01f0fbf8c68a2a8b481726c22d858
DIST pysvn-1.9.15.tar.gz 667161 BLAKE2B 35e9e0967d5c0b4cebf546e40df17b66c66406d0f8100c32e6e840220f60b0083c0ed3f3af5f54e2264d06905ea90970d6b7cbfad2bab872a14d5d4aea5900df SHA512 0809507134fd31f6bcc90217e7840eb166e2eb2ed56316010a549dd70f6f855599f596942574343cdefd5997947b12c847df2cd145669f50aa93f603e46a5ee0
+DIST pysvn-1.9.18.tar.gz 667827 BLAKE2B cd32b4ec55118becd496a9aab6f4dd2b9d57c82e12d5a08b18d36d0caffbafe7066ff45c9493a36499979e759d38dd6b15a68e7bb5819464362c2691e7599160 SHA512 0ca2924223cdc5f29e961e879db6b0f88e82b5c4c40df50169468dd5a72cbccddea9f0d1680ef4a54d45e89b4b2b2c3c22f5e76c66196783a89cac8b583b6623
EBUILD pysvn-1.9.15-r1.ebuild 1272 BLAKE2B d2ba9aca8484b8006bd6a1c2fd76995123b0e99070817585ba6013261924091c9ec0bbc2932a69e8aa88647a4b885e2444e7b40983e03d497096b709cd98b767 SHA512 1890856b74902478cd993e40034998f4a9e61528f420ee88877a0210474f6f77119189348764dfa4c13a19f9f4510dd4c2737587fb0a78059c9cb9b119d8e9af
+EBUILD pysvn-1.9.18.ebuild 1286 BLAKE2B 44702fb081011d73eb345d1c0fe651848070119f6a093a6b4561342bdcdf8e5643f8b32590a4cc126c625540858da8cf2b07c8fcea97a9ee9f3b7350e8b95354 SHA512 f736fc2540d63169831cc67c5de8ea97be4a62e0674ebb52e5962045f734f7c8400d7290a32cafa5376acd31be43fbb7be2d15dd088f236a60b80b28874f3338
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch b/dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch
new file mode 100644
index 000000000000..06a0bec16720
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch
@@ -0,0 +1,33 @@
+From 0f4a2071dfeb90357a3eba947d6dd7cc879675ce Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 29 Nov 2022 01:08:49 +0100
+Subject: [PATCH] Examples/Client/svn_cmd.py: Stop DeprecationWarning from
+ breaking tests with Python 3.11
+
+---
+ Examples/Client/svn_cmd.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/Examples/Client/svn_cmd.py b/Examples/Client/svn_cmd.py
+index 42e4c87..b8ef4ff 100644
+--- a/Examples/Client/svn_cmd.py
++++ b/Examples/Client/svn_cmd.py
+@@ -72,7 +72,14 @@ def initLocale():
+ locale.setlocale( locale.LC_ALL, '' )
+
+ else:
+- language_code, encoding = locale.getdefaultlocale()
++ import warnings
++
++ with warnings.catch_warnings():
++ if sys.version_info >= (3, 11):
++ warnings.filterwarnings("ignore", category=DeprecationWarning)
++
++ language_code, encoding = locale.getdefaultlocale()
++
+ if language_code is None:
+ language_code = 'en_GB'
+
+--
+2.38.1
+
diff --git a/dev-python/pysvn/pysvn-1.9.18.ebuild b/dev-python/pysvn/pysvn-1.9.18.ebuild
new file mode 100644
index 000000000000..ebc6f2e8f2cf
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.9.18.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="https://pysvn.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-7.0.2[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.18-tests-3.11.patch
+)
+
+python_prepare_all() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ cd Source || die
+ CC="$(tc-getCC)" CCC="$(tc-getCXX)" \
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/. )
+ if use examples; then
+ docinto examples
+ dodoc -r Examples/Client/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}