summaryrefslogtreecommitdiff
path: root/dev-python/pystatgrab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pystatgrab
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pystatgrab')
-rw-r--r--dev-python/pystatgrab/Manifest3
-rw-r--r--dev-python/pystatgrab/metadata.xml8
-rw-r--r--dev-python/pystatgrab/pystatgrab-0.7.ebuild29
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pystatgrab/Manifest b/dev-python/pystatgrab/Manifest
new file mode 100644
index 000000000000..26bc07cda8ab
--- /dev/null
+++ b/dev-python/pystatgrab/Manifest
@@ -0,0 +1,3 @@
+DIST pystatgrab-0.7.tar.gz 84472 BLAKE2B 3f56ce2dd363114f57fd99b9f3bccd42e7719bc248a8a00db2964efbc5917c218179a9efdc2fbb55e1c36a938316956603a90643407cf81b7651ec50a31a5b61 SHA512 ce239941eebe5390a9154d19891ab45fc410515bb7313083450ffd30cfe23457a1d7e2d0ccab4434c844bb6f2cbfe6080ecfd66db7728720e703ce01ea219366
+EBUILD pystatgrab-0.7.ebuild 695 BLAKE2B 7cc2810a641470418b9b9892287bccb743d231d902fc55ef243687df36e3873a3f7ce6752c5b77ea071becd0c588342c2c8197b1ca10c0b2f5c5a6c5a7c87152 SHA512 a368253941a0e54df4f41e3eb2016bc2842d201537eda3422c58ce825d7987eb3f5639c1020a3ea930cb2e798dfa96d1c740acc305d3d52b84e61d62946e9731
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/pystatgrab/metadata.xml b/dev-python/pystatgrab/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/dev-python/pystatgrab/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pystatgrab/pystatgrab-0.7.ebuild b/dev-python/pystatgrab/pystatgrab-0.7.ebuild
new file mode 100644
index 000000000000..7837d02418fc
--- /dev/null
+++ b/dev-python/pystatgrab/pystatgrab-0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION=" pystatgrab is a set of Python bindings for the libstatgrab library"
+HOMEPAGE="https://www.i-scream.org/pystatgrab/"
+SRC_URI="https://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/pystatgrab/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/libstatgrab-0.91"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test.py || die
+}