summaryrefslogtreecommitdiff
path: root/dev-python/pystache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pystache
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pystache')
-rw-r--r--dev-python/pystache/Manifest3
-rw-r--r--dev-python/pystache/metadata.xml17
-rw-r--r--dev-python/pystache/pystache-0.5.4.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pystache/Manifest b/dev-python/pystache/Manifest
new file mode 100644
index 000000000000..d7e74500ed0f
--- /dev/null
+++ b/dev-python/pystache/Manifest
@@ -0,0 +1,3 @@
+DIST pystache-0.5.4.tar.gz 75131 BLAKE2B 3f0b9feb9664b8fc0a78f230bd4cfabbf6ca05be254ff01cbff0c3f94ed54feb066c455bdf69c2e4a940c36d46442c446975b9f4bffa769a6b8bae0a72874e1e SHA512 4ac325e1431f58f740218c9ec309821db82d89989ef4ca7fc3536dea0ef1c90e8e85ebaa7df27f33129ca02252b84bcbd7429a1ed999b496f62f174dd66502cb
+EBUILD pystache-0.5.4.ebuild 597 BLAKE2B 663376b87b2716ca346f36e757917bf8145ea9526d9b6dd70824fc4fcbfc18681b4e36ed7f5edfb933913f576c86db9458647209d80ca15b872cf69187a6e728 SHA512 eca0fc97cf0d2eae64a82845755d20c38262ae43fa43a73236935f3fa8dd34c2946f33e82e56610f8f6b0de2c6c24245445f30a7a1a823385b8a48904672500b
+MISC metadata.xml 587 BLAKE2B b33d4b1a78e2a44eed11cf366ccc97b720599c3985c1a074c69bbd3ba1e9a2a9905a71f2013b62db3cfe519e28e2068ac7172dbb3a8fa4f84acd613d22a7edea SHA512 3d044de102f4c06604e6a53930b5232f97721fcd79f1ea3f14de5e4cee6497d6c4603cc3bcc45de5ac8f6358dc2a728002653b30d79af58a17ce627c22e58120
diff --git a/dev-python/pystache/metadata.xml b/dev-python/pystache/metadata.xml
new file mode 100644
index 000000000000..60c1f87f0988
--- /dev/null
+++ b/dev-python/pystache/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pystache is a Python implementation of Mustache.
+ Mustache is a framework-agnostic, logic-free
+ templating system for Ruby, inspired by ctemplate and etc.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">pystache</remote-id>
+ <remote-id type="github">defunkt/pystache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pystache/pystache-0.5.4.ebuild b/dev-python/pystache/pystache-0.5.4.ebuild
new file mode 100644
index 000000000000..650c606c58ce
--- /dev/null
+++ b/dev-python/pystache/pystache-0.5.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Mustache for Python"
+HOMEPAGE="https://github.com/defunkt/pystache"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests --verbose || die
+}