summaryrefslogtreecommitdiff
path: root/dev-python/pystache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
commit14fff03b5545ac6b6f575afd2e6174afbd294fdd (patch)
tree21be5aee55de4f6216e406157ad8c59a811ea202 /dev-python/pystache
parent9f51c386724b9543e88a9c0e1be57d44326f3116 (diff)
gentoo auto-resync : 27:08:2023 - 22:00:51
Diffstat (limited to 'dev-python/pystache')
-rw-r--r--dev-python/pystache/Manifest2
-rw-r--r--dev-python/pystache/pystache-0.6.5.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pystache/Manifest b/dev-python/pystache/Manifest
index a18dcc9e42ac..dec33af7ce87 100644
--- a/dev-python/pystache/Manifest
+++ b/dev-python/pystache/Manifest
@@ -1,3 +1,5 @@
DIST pystache-0.6.1.gh.tar.gz 279050 BLAKE2B 2c61ba260764aa4bf62039bfe1f844d34e26adc29af2f1e1d98619892bfabd3151aa1d34c69596389a68f0d84ce994ddf7114c091d42b497a17b300a5aff36cc SHA512 516d286f84d2c77650550365f6b219acb712376f0b7302fff2aba7dee4d64e3d3fc2d781782777dd37093f6debf52f9d2a40b6ed8b65aa5f7025ff762cb5efae
+DIST pystache-0.6.5.gh.tar.gz 272484 BLAKE2B 8b82aa8922480019e4833333f83d767ef19a1505e2fc708fef0d01c08353b5e600a077c1e86e36c412680381ff6fd310f83857038f383b8218b72269b4e5349b SHA512 e3054e0bff5c3bc6679bf22555dd3cfb2f31b241484c7e6201d37b7767a22f2f842912e3f61d8e2e2858615a4f99ef4192d885b60f84dfeffa1408370ccfba75
EBUILD pystache-0.6.1.ebuild 855 BLAKE2B 0d9dd909ac0325f5bfde6223bea8be023847bac85860bc8a12fc66b2f211470d00f2d3db5ae18f4f061f8ae256d4c34bb16312bf4460ae38f7da59cc999e5b85 SHA512 e794769e1798edc59c02c319ddc1d52b4ba5364ba11a3be74dc23b93bb28f119085bbc303e8edc2b1f39442f6e42a8629ab8f8a509c80385d6e9133047a6862e
+EBUILD pystache-0.6.5.ebuild 776 BLAKE2B ab017fd8d396a20f7b412abe42e806f2f2be3d12337fb09a11cdbab2a2d65f66b171e9d7135da84e2fa05adbd17522b8f77a904039865e93e9af4d0d5b32dacc SHA512 cd8695d176494b177cfbcc5a44ef59db6cb4343a6ddbd16205843658c26144f3bb93578847200cb8924d7f98a34c84a488a65e60fe5e62ee782c8dbfdd1b788d
MISC metadata.xml 692 BLAKE2B a4c6b4b29ac3976d0dd7cc01862d9e759314cd45e94b85788b4a8975bbf3785f9b75c06217fecfe3817c281331dc58aaba6015638a60b38614d5d62a60b31b6a SHA512 b0513af48c0691931b53becc62f2089ca9b394da79bd68be6892a58f0b1498a4fe7c6ff4a372160639fb5e59d32759d926235c202319affbd9e3a64ad29a2668
diff --git a/dev-python/pystache/pystache-0.6.5.ebuild b/dev-python/pystache/pystache-0.6.5.ebuild
new file mode 100644
index 000000000000..c10cd9359cc2
--- /dev/null
+++ b/dev-python/pystache/pystache-0.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Updated Python implementation of Mustache templating framework"
+HOMEPAGE="
+ https://github.com/PennyDreadfulMTG/pystache/
+ https://pypi.org/project/pystache/
+"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/PennyDreadfulMTG/pystache.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/PennyDreadfulMTG/pystache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest