summaryrefslogtreecommitdiff
path: root/dev-python/pyspnego/pyspnego-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 07:47:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 07:47:44 +0000
commitfcefa9aa213e0ff26901b351fccd47393113ae5d (patch)
tree16ff06e1d47c8dc06b954f726f24cd6f941e3596 /dev-python/pyspnego/pyspnego-0.7.0.ebuild
parent8bb75334c4b9f91e9f95784e986ed31b4bc11f92 (diff)
gentoo auto-resync : 19:12:2022 - 07:47:44
Diffstat (limited to 'dev-python/pyspnego/pyspnego-0.7.0.ebuild')
-rw-r--r--dev-python/pyspnego/pyspnego-0.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyspnego/pyspnego-0.7.0.ebuild b/dev-python/pyspnego/pyspnego-0.7.0.ebuild
new file mode 100644
index 000000000000..372520083949
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}